diff configure.in @ 33:c8ec7877432e

2002-10-06 Brian Masney <masneyb@gftp.org> * src/gtk/delete_dialog.c, src/gtk/gftp-gtk.c, src/gtk/misc-gtk.c, src/gtk/transfer.c - Fixed dead-locks with GDK_THREADS_{ENTER,LEAVE} * configure.in, src/gtk/Makefile.am - Use GTHREAD_LIBS 2002-10-03 Brian Masney <masneyb@gftp.org> * Makefile.am - remove intl and m4 directory from subdirs. autogen.sh will automagically add these for me. * autogen.sh - remove check for libtool * configure.in - link in gthread * cvsclean - added this script * *.[ch] - added $Id$ tags * debian/* - updated files from Debian maintainer
author masneyb
date Mon, 07 Oct 2002 10:40:43 +0000
parents b3e16d1f19c9
children 5a178bd04ca5
line wrap: on
line diff
--- a/configure.in	Thu Oct 03 12:06:18 2002 +0000
+++ b/configure.in	Mon Oct 07 10:40:43 2002 +0000
@@ -160,6 +160,11 @@
 GFTP_GTK=""
 PTHREAD_CFLAGS=""
 PTHREAD_LIBS=""
+
+# I don't have PKG_CHECK_MODULES or AM_PATH_GLIB check for gthread because
+# the text port doesn't need to be compiled against the thread libraries
+GTHREAD_LIBS=""
+
 if test "x$enable_gtkport" = "x1" ; then
   if test "x$enable_gtk20" = "x1" ; then
     PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 1.3.8, GFTP_GTK=gftp-gtk)
@@ -167,6 +172,9 @@
 
   if test "x$GFTP_GTK" = "x" ; then
     AM_PATH_GTK(1.2.3, GFTP_GTK=gftp-gtk, AC_MSG_WARN(gFTP needs GTK+ 1.2.3 or higher for the graphical version. Only building the text version))
+    GTHREAD_LIBS="-lgthread"
+  else
+    GTHREAD_LIBS="-lgthread-2.0"
   fi
 
   if test "x$GFTP_GTK" = xgftp-gtk; then
@@ -232,6 +240,7 @@
 fi
 AC_SUBST(PTHREAD_CFLAGS)
 AC_SUBST(PTHREAD_LIBS)
+AC_SUBST(GTHREAD_LIBS)
 AC_SUBST(GFTP_GTK)
 
 AM_GNU_GETTEXT