diff configure.in @ 26:d74bfa342116

2002-09-24 gettextize <bug-gnu-gettext@gnu.org> * Makefile.am (SUBDIRS): Add intl, (ACLOCAL_AMFLAGS): New variable. (EXTRA_DIST): Add config.rpath mkinstalldirs. * configure.in (AC_OUTPUT): Add intl/Makefile, 2002-09-24 Brian Masney <masneyb@gftp.org> * lib/config_file.c - separated saving of bookmarks from gftp_write_config_file() to gftp_write_bookmarks_file(). Bookmarks will no longer be rewritten to disk every time gFTP exits * src/gtk/bookmarks.c - call gftp_write_bookmarks_file() instead of gftp_write_config_file() when altering a bookmark * configure.in - Fixed problem with the text port being compiled against glib 1.2 if we wanted it to be compiled against glib 2.0 instead * autogen.sh - add this build script
author masneyb
date Tue, 24 Sep 2002 12:18:40 +0000
parents 6b2e606554aa
children b3e16d1f19c9
line wrap: on
line diff
--- a/configure.in	Tue Sep 24 11:21:32 2002 +0000
+++ b/configure.in	Tue Sep 24 12:18:40 2002 +0000
@@ -30,6 +30,8 @@
 AC_C_CONST
 AC_C_INLINE
 
+AM_MAINTAINER_MODE
+
 AC_PROG_AWK
 AC_PROG_INSTALL
 AC_PROG_LN_S
@@ -54,12 +56,12 @@
 AC_FUNC_UTIME_NULL
 AC_CHECK_FUNCS(gai_strerror getaddrinfo getcwd gettimeofday getwd mkdir mktime putenv rmdir select socket strdup strstr strtod strtol uname)
 
-if test "x$enable_gtk20" = "x1" ; then
-  PKG_CHECK_MODULES(GLIB, glib-2.0 >= 1.3.8)
+if test "x$GFTP_TEXT" = "x" -a "x$enable_gtk20" = "x0" ; then
+  AM_PATH_GLIB(1.2.3, , AC_MSG_ERROR(gFTP needs GLIB 1.2.3 or higher))
 fi
 
-if test "x$GFTP_TEXT" = "x" ; then
-  AM_PATH_GLIB(1.2.3, , AC_MSG_ERROR(gFTP needs GLIB 1.2.3 or higher))
+if test "x$enable_gtk20" = "x1" ; then
+  PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.0.0)
 fi
 
 GFTP_TEXT=""
@@ -97,7 +99,7 @@
       if test x${HAVE_LIBREADLINE} = xtrue ; then
         echo "  Using -lreadline -lncurses"
         EXTRA_LIBREADLINE_DEPS=-lncurses
-        AC_DEFINE(HAVE_LIBREADLINE, [1])
+        AC_DEFINE(HAVE_LIBREADLINE, [1], [Define if the text port uses readline])
       else
         unset ac_cv_lib_readline_readline
         AC_CHECK_LIB(readline, readline, HAVE_LIBREADLINE=true,
@@ -105,7 +107,7 @@
         if test x${HAVE_LIBREADLINE} = xtrue ; then
           echo "  Using -lreadline -lcurses"
           EXTRA_LIBREADLINE_DEPS=-lcurses
-          AC_DEFINE(HAVE_LIBREADLINE, [1])
+          AC_DEFINE(HAVE_LIBREADLINE, [1], [Define if the text port uses readline])
         else
           unset ac_cv_lib_readline_readline
           AC_CHECK_LIB(readline, readline, HAVE_LIBREADLINE=true,
@@ -113,15 +115,15 @@
           if test x${HAVE_LIBREADLINE} = xtrue ; then
             echo "  Using -lreadline -ltermcap"
             EXTRA_LIBREADLINE_DEPS=-ltermcap
-            AC_DEFINE(HAVE_LIBREADLINE, [1])
+            AC_DEFINE(HAVE_LIBREADLINE, [1], [Define if the text port uses readline])
           else
             unset ac_cv_lib_readline_readline
             AC_CHECK_LIB(readline, readline, HAVE_LIBREADLINE=true,
                          HAVE_LIBREADLINE=false)
             if test x${HAVE_LIBREADLINE} = xtrue ; then
-              AC_DEFINE(HAVE_LIBREADLINE, [1])
+              AC_DEFINE(HAVE_LIBREADLINE, [1], [Define if the text port uses readline])
             else
-              AC_DEFINE(HAVE_LIBREADLINE, [0])
+              AC_DEFINE(HAVE_LIBREADLINE, [0], [Define if the text port uses readline])
             fi
           fi
         fi
@@ -132,14 +134,14 @@
                    HAVE_LIBREADLINE=false, ${EXTRA_LIBREADLINE_DEPS})
       if test x${HAVE_LIBREADLINE} = xtrue ; then
         echo "  Using -lreadline ${EXTRA_LIBREADLINE_DEPS}"
-        AC_DEFINE(HAVE_LIBREADLINE, [1])
+        AC_DEFINE(HAVE_LIBREADLINE, [1], [Define if the text port uses readline])
       else
-        AC_DEFINE(HAVE_LIBREADLINE, [0])
+        AC_DEFINE(HAVE_LIBREADLINE, [0], [Define if the text port uses readline])
       fi
     fi
   else
     HAVE_LIBREADLINE=false
-    AC_DEFINE(HAVE_LIBREADLINE, [0])
+    AC_DEFINE(HAVE_LIBREADLINE, [0], [Define if the text port uses readline])
   fi
   if test x${HAVE_LIBREADLINE} = xtrue; then
     READLINE_LIBS="-lreadline ${EXTRA_LIBREADLINE_DEPS}"
@@ -149,11 +151,7 @@
 
 AC_CHECK_LIB(m, log10, EXTRA_LIBS="$EXTRA_LIBS -lm")
 
-if test "x$enable_dmalloc" = "x1" ; then
-  AC_CHECK_LIB(dmalloc, dmalloc_shutdown, [
-	AC_DEFINE(HAVE_DMALLOC)
-	EXTRA_LIBS="$EXTRA_LIBS -ldmalloc"])
-fi
+AM_WITH_DMALLOC
 
 AC_SUBST(EXTRA_LIBS)
 AC_SUBST(READLINE_LIBS)
@@ -236,6 +234,6 @@
 AC_SUBST(PTHREAD_LIBS)
 AC_SUBST(GFTP_GTK)
 
-AM_GNU_GETTEXT
+AM_GNU_GETTEXT([external])
 
-AC_OUTPUT(Makefile intl/Makefile po/Makefile.in docs/Makefile docs/sample.gftp/Makefile src/gftp src/Makefile src/gtk/Makefile src/text/Makefile lib/Makefile gftp.spec)
+AC_OUTPUT(Makefile docs/Makefile docs/sample.gftp/Makefile src/gftp src/Makefile src/gtk/Makefile src/text/Makefile lib/Makefile gftp.spec)