diff configure.in @ 649:eaede7f6c2f8

2004-12-31 Brian Masney <masneyb@gftp.org> * lib/gftp.h - when using HPUX, define the size of off_t as size long * configure.in - HPUX thread fixes
author masneyb
date Fri, 31 Dec 2004 13:25:40 +0000
parents 43a0556c994f
children 2d3ea4db3106
line wrap: on
line diff
--- a/configure.in	Fri Dec 24 11:26:52 2004 +0000
+++ b/configure.in	Fri Dec 31 13:25:40 2004 +0000
@@ -205,6 +205,10 @@
     case $host in
       *-hpux*)
         AC_CHECK_LIB(rt, sem_init)
+
+        # From H.Merijn Brand <h.m.brand@hccnet.nl>
+        echo '#define pthread_attr_init(x) __pthread_attr_init_system(x)' >>confdefs.h
+        echo '#define pthread_create(x) __pthread_create_system(x)' >>confdefs.h
         ;;
     esac
 
@@ -233,11 +237,6 @@
 
     # I took some of these from the glib 1.3.3 configure.in
     case $host in
-      *-hpux*)
-        # From H.Merijn Brand <h.m.brand@hccnet.nl>
-        echo '#define pthread_attr_init(x) __pthread_attr_init_system(x)' >>confdefs.h
-        echo '#define pthread_create(x) __pthread_create_system(x)' >>confdefs.h
-        ;;
       *-aix*)
         PTHREAD_CFLAGS="$PTHREAD_CFLAGS -D_THREAD_SAFE"
         if test x"$GCC" = xyes; then