view debian/rules @ 303:3b9d5797050f

2003-11-2 Brian Masney <masneyb@gftp.org> * lib/rfc2068.c (rfc2068_chunked_read) - more improvements to this function so that it will parse more chunked file transfers correctly. * lib/misc.c lib/gftp.h lib/rfc2068.c src/gtk/bookmarks.c src/gtk/dnd.c - removed remove_double_slashes(). Call gftp_build_path() to build the paths. This now allows Novell directory listings with //server * lib/protocols.c src/gtk/transfer.c lib/gftp.h - added variable conn_error_no_timeout to gftp_transfer structure. If this is enabled, if the remote connection to the server timed out, don't wait and immediately reconnect. So far, the only time this is used is when the user was editing a file and it is to be uploaded back to the server. * src/gtk/gftp-gtk.h src/gtk/transfer.c - add_file_transfer() now returns the struct gftp_transfer that was just added. * src/gtk/misc-gtk.c (update_directory_download_progress) - don't make the window a popup and remove the window decorations * src/text/gftp-text.c - don't populate the transfer_direction variable in struct gftp_transfer. This is only needed by the GTK+ port and will hopefully be taken out soon. * lib/gftp.h - remove gftp_transfer_type enum. It wasn't used anymore.
author masneyb
date Mon, 03 Nov 2003 02:14:05 +0000
parents e599812712f0
children a2ec3572dea2
line wrap: on
line source

#!/usr/bin/make -f
# Derived from dh_make example.

arch := $(shell dpkg-architecture -qDEB_BUILD_ARCH)

#export DH_VERBOSE=1
export DH_COMPAT=2

ggtmp := $(CURDIR)/debian/gftp-gtk
gttmp := $(CURDIR)/debian/gftp-text

CFLAGS := -O2
ifneq "$(findstring debug,$(DEB_BUILD_OPTIONS))" ""
CFLAGS += -g
endif
ifeq "$(arch)" "alpha"
CFLAGS += -mieee
endif

build: build-stamp
build-stamp:
	dh_testdir
	CFLAGS="$(CFLAGS)" ./configure --prefix=/usr --mandir='$${prefix}/share/man' --enable-textport=yes
	$(MAKE) 
	touch $@

clean:
	dh_testdir
	dh_testroot
#	rm -f debian/dirs debian/docs
	rm -f debian/dirs
	[ ! -f Makefile ] || $(MAKE) distclean
	dh_clean build-stamp

install: build-stamp
	dh_testdir
	dh_testroot
	dh_clean -k
	$(MAKE) install prefix=$(ggtmp)/usr
	ln -s gftp.1.gz $(ggtmp)/usr/share/man/man1/gftp-gtk.1.gz
	dh_movefiles --sourcedir=debian/gftp-gtk -pgftp-common \
          usr/share/locale usr/share/gftp/gftprc usr/share/gftp/bookmarks \
          usr/share/man/man1/gftp.1 usr/bin/gftp
	dh_installdirs -pgftp-gtk usr/lib/menu

	# Install menu file manualy into the gftp-common file because
	# dh_installmenu cannot do it for me
	install -p -m644 debian/menu debian/gftp-gtk/usr/lib/menu/gftp
	echo "# Automatically added by dh_installmenu">> debian/gftp-gtk.postinst.debhelper
	sed "" /usr/share/debhelper/autoscripts/postinst-menu >> debian/gftp-gtk.postinst.debhelper
	echo '# End automatically added section' >> debian/gftp-gtk.postinst.debhelper
	echo "# Automatically added by dh_installmenu">> debian/gftp-gtk.postrm.debhelper
	sed "" /usr/share/debhelper/autoscripts/postrm-menu >> debian/gftp-gtk.postrm.debhelper
	echo '# End automatically added section' >> debian/gftp-gtk.postrm.debhelper

	dh_movefiles --sourcedir=debian/gftp-gtk -pgftp-text usr/bin/gftp-text
	dh_installdirs -pgftp-text usr/share/man/man1
	ln -s gftp.1.gz $(gttmp)/usr/share/man/man1/gftp-text.1.gz
	rm -f $(ggtmp)/usr/share/gftp/COPYING # we have the GPL elsewhere
	find $(ggtmp)/usr -type d -empty | xargs -r rmdir -p --ignore-fail-on-non-empty

binary-indep:
# Nothing to do, no architecture independent packages here.
# locales (gftp-common) have endianness

binary-arch: install
	dh_testdir
	dh_testroot
	dh_installdocs -a
	dh_installdocs -An -pgftp-gtk -pgftp-text README TODO
	dh_installchangelogs -a ChangeLog
	#dh_installmenu -a --package=gftp-gtk
ifeq "$(findstring nostrip,$(DEB_BUILD_OPTIONS))" ""
	dh_strip -a
endif
	dh_compress -a
	dh_fixperms -a
	dh_installdeb -a
	dh_shlibdeps -a
	dh_gencontrol -a
	dh_md5sums -a
	dh_builddeb -a

binary: binary-indep binary-arch
.PHONY: build clean binary-indep binary-arch binary install