diff mpegvideo.c @ 9721:5d0f71ba8648 libavcodec

Rename alloc_picture to ff_alloc_picture and move its definition in mpegvideo.h to avoid including mpegvideo_common.h in mpeg12.c, because it contains motion code.
author bcoudurier
date Wed, 27 May 2009 19:55:35 +0000
parents 15660ad4c641
children 6487152f17f2
line wrap: on
line diff
--- a/mpegvideo.c	Wed May 27 18:59:24 2009 +0000
+++ b/mpegvideo.c	Wed May 27 19:55:35 2009 +0000
@@ -219,7 +219,7 @@
  * allocates a Picture
  * The pixels are allocated/set by calling get_buffer() if shared=0
  */
-int alloc_picture(MpegEncContext *s, Picture *pic, int shared){
+int ff_alloc_picture(MpegEncContext *s, Picture *pic, int shared){
     const int big_mb_num= s->mb_stride*(s->mb_height+1) + 1; //the +1 is needed so memset(,,stride*height) does not sig11
     const int mb_array_size= s->mb_stride*s->mb_height;
     const int b8_array_size= s->b8_stride*s->mb_height*2;
@@ -917,7 +917,7 @@
 
         pic->coded_picture_number= s->coded_picture_number++;
 
-        if(alloc_picture(s, pic, 0) < 0)
+        if(ff_alloc_picture(s, pic, 0) < 0)
             return -1;
 
         s->current_picture_ptr= pic;