diff mpegvideo.h @ 9721:5d0f71ba8648 libavcodec

Rename alloc_picture to ff_alloc_picture and move its definition in mpegvideo.h to avoid including mpegvideo_common.h in mpeg12.c, because it contains motion code.
author bcoudurier
date Wed, 27 May 2009 19:55:35 +0000
parents 15660ad4c641
children ffc0f9de5743
line wrap: on
line diff
--- a/mpegvideo.h	Wed May 27 18:59:24 2009 +0000
+++ b/mpegvideo.h	Wed May 27 19:55:35 2009 +0000
@@ -711,6 +711,12 @@
 void ff_init_block_index(MpegEncContext *s);
 void ff_copy_picture(Picture *dst, Picture *src);
 
+/**
+ * allocates a Picture
+ * The pixels are allocated/set by calling get_buffer() if shared=0
+ */
+int ff_alloc_picture(MpegEncContext *s, Picture *pic, int shared);
+
 extern const enum PixelFormat ff_pixfmt_list_420[];
 extern const enum PixelFormat ff_hwaccel_pixfmt_list_420[];