diff mpegvideo_enc.c @ 9721:5d0f71ba8648 libavcodec

Rename alloc_picture to ff_alloc_picture and move its definition in mpegvideo.h to avoid including mpegvideo_common.h in mpeg12.c, because it contains motion code.
author bcoudurier
date Wed, 27 May 2009 19:55:35 +0000
parents cc0380d2bbc3
children 0bfb23c7633d
line wrap: on
line diff
--- a/mpegvideo_enc.c	Wed May 27 18:59:24 2009 +0000
+++ b/mpegvideo_enc.c	Wed May 27 19:55:35 2009 +0000
@@ -817,14 +817,14 @@
             pic->data[i]= pic_arg->data[i];
             pic->linesize[i]= pic_arg->linesize[i];
         }
-        alloc_picture(s, (Picture*)pic, 1);
+        ff_alloc_picture(s, (Picture*)pic, 1);
     }else{
         i= ff_find_unused_picture(s, 0);
 
         pic= (AVFrame*)&s->picture[i];
         pic->reference= 3;
 
-        alloc_picture(s, (Picture*)pic, 0);
+        ff_alloc_picture(s, (Picture*)pic, 0);
 
         if(   pic->data[0] + INPLACE_OFFSET == pic_arg->data[0]
            && pic->data[1] + INPLACE_OFFSET == pic_arg->data[1]
@@ -1150,7 +1150,7 @@
             Picture *pic= &s->picture[i];
 
             pic->reference              = s->reordered_input_picture[0]->reference;
-            alloc_picture(s, pic, 0);
+            ff_alloc_picture(s, pic, 0);
 
             /* mark us unused / free shared pic */
             if(s->reordered_input_picture[0]->type == FF_BUFFER_TYPE_INTERNAL)