diff gif.c @ 9431:932543edc1d2 libavcodec

Rename pbBufPtr() to put_bits_ptr(). The new name is more readable and consistent with the FFmpeg naming style.
author stefano
date Mon, 13 Apr 2009 16:59:38 +0000
parents 4cb7c65fc775
children 38cfe222e1a4
line wrap: on
line diff
--- a/gif.c	Mon Apr 13 16:47:17 2009 +0000
+++ b/gif.c	Mon Apr 13 16:59:38 2009 +0000
@@ -126,9 +126,9 @@
             put_bits(&p, 9, 0x101); /* end of stream */
             flush_put_bits(&p);
         }
-        if(pbBufPtr(&p) - p.buf > 0) {
-            bytestream_put_byte(bytestream, pbBufPtr(&p) - p.buf); /* byte count of the packet */
-            bytestream_put_buffer(bytestream, p.buf, pbBufPtr(&p) - p.buf); /* the actual buffer */
+        if(put_bits_ptr(&p) - p.buf > 0) {
+            bytestream_put_byte(bytestream, put_bits_ptr(&p) - p.buf); /* byte count of the packet */
+            bytestream_put_buffer(bytestream, p.buf, put_bits_ptr(&p) - p.buf); /* the actual buffer */
             p.buf_ptr = p.buf; /* dequeue the bytes off the bitstream */
         }
         left-=GIF_CHUNKS;