diff motion_est_template.c @ 5083:ce36118abbbb libavcodec

rename attribute_unused to av_unused and moves its declaration to common.h patch by Carl Eugen Hoyos cehoyos chez ag or at original thread: [FFmpeg-devel] [PATCH] attribute_unused -> av_unused date: 05/29/2007 01:23 PM
author benoit
date Wed, 30 May 2007 09:32:25 +0000
parents efeca638ad20
children 2b72f9bc4f06
line wrap: on
line diff
--- a/motion_est_template.c	Tue May 29 16:51:55 2007 +0000
+++ b/motion_est_template.c	Wed May 30 09:32:25 2007 +0000
@@ -27,11 +27,11 @@
 
 //lets hope gcc will remove the unused vars ...(gcc 3.2.2 seems to do it ...)
 #define LOAD_COMMON\
-    uint32_t attribute_unused * const score_map= c->score_map;\
-    const int attribute_unused xmin= c->xmin;\
-    const int attribute_unused ymin= c->ymin;\
-    const int attribute_unused xmax= c->xmax;\
-    const int attribute_unused ymax= c->ymax;\
+    uint32_t av_unused * const score_map= c->score_map;\
+    const int av_unused xmin= c->xmin;\
+    const int av_unused ymin= c->ymin;\
+    const int av_unused xmax= c->xmax;\
+    const int av_unused ymax= c->ymax;\
     uint8_t *mv_penalty= c->current_mv_penalty;\
     const int pred_x= c->pred_x;\
     const int pred_y= c->pred_y;\