Mercurial > libavcodec.hg
graph
-
Do not scare the user with error messages when everything is ok. libavcodecFri, 25 Jul 2008 14:52:58 +0000, by michael
-
Make remove_short() match remove_long() in that it calls unreference_pic(). libavcodecFri, 25 Jul 2008 14:00:01 +0000, by michael
-
Removing yet another weird field pic special case, libavcodecFri, 25 Jul 2008 13:40:13 +0000, by michael
-
Make remove_long() call unreference_pic() internally. libavcodecFri, 25 Jul 2008 13:09:06 +0000, by michael
-
Merge oddly duplicated remove_long/remove_long_at_index() function. libavcodecFri, 25 Jul 2008 12:56:58 +0000, by michael
-
Remove another of these obfuscated special cases for field pictures libavcodecFri, 25 Jul 2008 12:23:41 +0000, by michael
-
Simplify mmco setup code used in IDR pictures. libavcodecFri, 25 Jul 2008 12:12:25 +0000, by michael
-
Assert that long_ref has been cleared for released pics. libavcodecFri, 25 Jul 2008 11:54:03 +0000, by michael
-
Clear long_ref when a frame is no longer a long_ref. libavcodecFri, 25 Jul 2008 11:52:40 +0000, by michael
-
Make sure mmco index is 0 (instead of uninitialized) in all error returns. libavcodecFri, 25 Jul 2008 11:48:32 +0000, by michael
-
Simplify strange obfuscated code in MMCO_LONG handling. libavcodecFri, 25 Jul 2008 00:13:02 +0000, by michael
-
Set field_poc (it was half uninitialized before) and use it libavcodecThu, 24 Jul 2008 23:43:44 +0000, by michael
-
cosmetics: Fix two common typos: wont --> will not, lets --> let us. libavcodecThu, 24 Jul 2008 17:09:28 +0000, by diego
-
Remove AltiVec vector declaration compiler compatibility macros. libavcodecThu, 24 Jul 2008 10:53:32 +0000, by diego
-
Rename update() function to backward_filter() and add a doxy comment libavcodecThu, 24 Jul 2008 04:29:23 +0000, by vitor
-
Follow FFmpeg convention of returning negative values on error in eval_lpc_coeffs() libavcodecThu, 24 Jul 2008 04:07:50 +0000, by vitor
-
Rename pred() to eval_lpc_coeffs() and add a doxy comment libavcodecThu, 24 Jul 2008 04:05:41 +0000, by vitor
-
Give parameters of do_hybrid_window() more meaningful names libavcodecThu, 24 Jul 2008 03:28:01 +0000, by vitor
-
Rename co() function to the much more descriptive name of libavcodecThu, 24 Jul 2008 03:23:51 +0000, by vitor
-
Simplify co(): write constant in a more readable way libavcodecThu, 24 Jul 2008 03:22:19 +0000, by vitor
-
Simplify co(), use memcpy/memmove and colmult() when useful. libavcodecThu, 24 Jul 2008 03:19:52 +0000, by vitor
-
Reset prev_frame_num for idr frames as required by the spec. libavcodecThu, 24 Jul 2008 00:45:18 +0000, by michael
-
Remove truncated support, use an AVParser if you used that, it is the same. libavcodecWed, 23 Jul 2008 14:44:07 +0000, by michael
-
Reduce the loglevel on a log message in the Nellymoser decoder. Related to Roundup 447. libavcodecWed, 23 Jul 2008 12:21:56 +0000, by banan
-
My commit at r14340 was not the right solution. For a monochromatic libavcodecWed, 23 Jul 2008 05:54:34 +0000, by vitor
-
Do declaration and initialization separately in elbg.c libavcodecWed, 23 Jul 2008 03:56:13 +0000, by vitor
-
When picking a "high utility centroid" do not pick one libavcodecWed, 23 Jul 2008 03:55:37 +0000, by vitor
-
The codebook generator algorithm involves picking three libavcodecWed, 23 Jul 2008 03:54:31 +0000, by vitor