log ra144.c @ 12488:351a81a23343 libavcodec

age author description
Fri, 11 Jun 2010 08:05:17 +0000 vitor Split do_output_subblock() into common code and decoder specific parts libavcodec
Fri, 11 Jun 2010 08:04:22 +0000 vitor Cosmetics: indent libavcodec
Fri, 11 Jun 2010 08:03:43 +0000 vitor Add ff_ prefix to non-static functions libavcodec
Fri, 11 Jun 2010 08:01:51 +0000 vitor Split ra144.c in common code (to be shared with the future encoder) and libavcodec base ra144.h@8a00d5658628
Tue, 30 Mar 2010 23:30:55 +0000 stefano Define AVMediaType enum, and use it instead of enum CodecType, which libavcodec
Mon, 08 Mar 2010 21:19:56 +0000 mru Move ff_sqrt() to libavutil/intmath.h libavcodec
Sat, 13 Feb 2010 17:42:58 +0000 vitor Fix reading beyond buffer end on RA144Context.lpc_tables. libavcodec
Tue, 05 Jan 2010 16:25:41 +0000 vitor Use correct context for av_log(), should prevent a crash for malformed files. libavcodec
Mon, 13 Apr 2009 16:20:26 +0000 stefano Rename bitstream.h to get_bits.h. libavcodec
Tue, 07 Apr 2009 15:59:50 +0000 rbultje Implement avcodec_decode_video2(), _audio3() and _subtitle2() which takes an libavcodec
Sun, 01 Mar 2009 23:41:39 +0000 mru RA144: work around gcc bug/oddity on ARM libavcodec
Sun, 01 Mar 2009 11:16:57 +0000 vitor Reindent after last commit libavcodec
Sun, 01 Mar 2009 11:14:21 +0000 vitor Do not read uninitialized buffer, no matter if it will be multiplied by libavcodec
Fri, 24 Oct 2008 21:29:23 +0000 diego Split off celp_filters.[ch] from acelp_filters.[ch] for the QCELP decoder. libavcodec
Thu, 11 Sep 2008 08:13:23 +0000 diego misc spelling/wording/grammar fixes libavcodec
Mon, 08 Sep 2008 18:51:33 +0000 vitor Normalize triplets in gain_val_tab[][] so gain_exp_tab[] can be just an libavcodec
Mon, 08 Sep 2008 18:18:29 +0000 vitor Pass directly variable 'a' to interp instead of evaluating it from num_blocks libavcodec
Mon, 08 Sep 2008 18:16:00 +0000 vitor Simplify if() in copy_and_dup() libavcodec
Mon, 08 Sep 2008 18:14:37 +0000 vitor Add av_cold attribute to decode_init() libavcodec
Mon, 08 Sep 2008 18:13:53 +0000 vitor Cosmetics: Make the two additional units in size more clear libavcodec
Sat, 06 Sep 2008 11:46:29 +0000 vitor Test a var for overflow just after it is set libavcodec
Sat, 06 Sep 2008 11:45:10 +0000 vitor Remove useless parentheses. libavcodec
Wed, 06 Aug 2008 21:19:30 +0000 vitor Cosmetics: rename loop counters in eval_refl() libavcodec
Wed, 06 Aug 2008 21:16:24 +0000 vitor Simplify eval_refl(): do not store a buffer value in a var when the buffer could be used directly libavcodec
Wed, 06 Aug 2008 21:04:40 +0000 vitor Simplify eval_refl(): s/b == 0/!b/ libavcodec
Wed, 06 Aug 2008 21:02:56 +0000 vitor Simplify range checking in eval_refl(). Before the libavcodec
Wed, 06 Aug 2008 20:39:28 +0000 vitor Cosmetics: reindent libavcodec
Wed, 06 Aug 2008 20:38:23 +0000 vitor Simplify do_output_subblock(): Remove a unneeded memcpy libavcodec
Wed, 06 Aug 2008 05:24:21 +0000 vitor Simplify eval_refl(): return directly when needed instead of storing the return value in a variable libavcodec
Wed, 06 Aug 2008 05:11:46 +0000 vitor Simplify rms(): merge a few operations in the same statement libavcodec
Wed, 06 Aug 2008 05:08:48 +0000 vitor Cosmetical simplification in t_sqrt() libavcodec
Wed, 06 Aug 2008 05:06:10 +0000 vitor Check available size before writing in decode_frame() libavcodec
Thu, 31 Jul 2008 10:47:31 +0000 pross Modify all codecs to report their supported input and output sample format(s). libavcodec
Tue, 29 Jul 2008 18:07:11 +0000 vitor Cosmetics: rename loop counter vars to i,j libavcodec
Sun, 29 Jun 2008 21:37:03 +0000 vitor Make ff_acelp_lp_synthesis_filter() receives a pointer to the actual filter coefficients and not the pointer minus one libavcodec
Sun, 29 Jun 2008 13:12:31 +0000 vitor Update copyright libavcodec
Sun, 29 Jun 2008 11:21:06 +0000 vitor Use ff_acelp_lp_synthesis_filter() instead of duplicating it libavcodec
Sun, 29 Jun 2008 07:58:46 +0000 vitor Doxy comment libavcodec
Tue, 24 Jun 2008 21:32:34 +0000 vitor Simplify interp() libavcodec
Tue, 24 Jun 2008 21:30:09 +0000 vitor More cosmetics libavcodec
Tue, 24 Jun 2008 21:29:18 +0000 vitor Cosmetics libavcodec
Tue, 24 Jun 2008 18:38:55 +0000 vitor Use lpc_coef[2] instead of lpc_coef and lpc_coef_old libavcodec
Tue, 24 Jun 2008 18:13:44 +0000 vitor Remove unused entries from lpc_refl_cb* libavcodec
Tue, 24 Jun 2008 18:06:30 +0000 vitor Remove unused entries from energy_tab libavcodec
Mon, 23 Jun 2008 21:10:59 +0000 vitor Merge the >> 4 calculation of cb1_base in the table libavcodec
Mon, 23 Jun 2008 21:00:28 +0000 vitor Consistency: make the output buffer the first argument of functions libavcodec
Mon, 23 Jun 2008 20:53:05 +0000 vitor Use sizeof() intead of hardcoding the values libavcodec
Mon, 23 Jun 2008 20:46:42 +0000 vitor Simplify libavcodec
Mon, 23 Jun 2008 20:44:58 +0000 vitor Simplify libavcodec
Mon, 23 Jun 2008 20:42:36 +0000 vitor It makes more sense to return 1 here in case of overflow. libavcodec
Mon, 23 Jun 2008 20:39:28 +0000 vitor Cosmetics: indent libavcodec
Mon, 23 Jun 2008 20:39:09 +0000 vitor Remove unneeded check libavcodec
Mon, 23 Jun 2008 20:37:53 +0000 vitor rescale_rms() should use unsigned ints libavcodec
Mon, 23 Jun 2008 20:35:02 +0000 vitor Move factor multiplication out of irms() libavcodec
Mon, 23 Jun 2008 20:33:31 +0000 vitor This should be signed libavcodec
Mon, 23 Jun 2008 20:28:00 +0000 vitor More comments removal/fixes libavcodec
Mon, 23 Jun 2008 20:26:57 +0000 vitor Remove useless comment libavcodec
Mon, 23 Jun 2008 20:26:24 +0000 vitor More comments improvement libavcodec
Mon, 23 Jun 2008 20:24:06 +0000 vitor Document defines better libavcodec
Mon, 23 Jun 2008 20:20:29 +0000 vitor Remove useless define libavcodec
Mon, 23 Jun 2008 20:18:51 +0000 vitor Rename rotate_buffer() to copy_and_dup() and doxy it libavcodec
Mon, 23 Jun 2008 20:13:07 +0000 vitor Simplify t_sqrt() libavcodec
Mon, 23 Jun 2008 20:12:12 +0000 vitor Add doxy comment libavcodec
Mon, 23 Jun 2008 20:06:36 +0000 vitor Rename var libavcodec
Mon, 23 Jun 2008 20:05:42 +0000 vitor Move code unrelated to lpc filtering out of lpc_filter() libavcodec
Mon, 23 Jun 2008 19:59:42 +0000 vitor Simplify rotate_buffer() libavcodec
Sun, 22 Jun 2008 20:10:16 +0000 vitor Cosmetics libavcodec
Sun, 22 Jun 2008 20:09:13 +0000 vitor Avoid a memcpy. Code is also simpler now in my opinion. libavcodec
Fri, 20 Jun 2008 20:46:07 +0000 vitor Do not write junk in the end of truncated files. FATE libavcodec
Thu, 19 Jun 2008 20:51:56 +0000 vitor Misc cosmetics libavcodec
Thu, 19 Jun 2008 20:48:00 +0000 vitor Remove useless comment libavcodec
Thu, 19 Jun 2008 20:43:34 +0000 vitor Last table renaming libavcodec
Thu, 19 Jun 2008 20:36:23 +0000 vitor Yet more table renaming libavcodec
Thu, 19 Jun 2008 20:31:34 +0000 vitor More table renaming libavcodec
Thu, 19 Jun 2008 20:28:28 +0000 vitor Rename table libavcodec
Thu, 19 Jun 2008 19:37:51 +0000 vitor Rename vars: s/decsp/out/ libavcodec
Thu, 19 Jun 2008 19:35:59 +0000 vitor Rename function libavcodec
Thu, 19 Jun 2008 19:34:38 +0000 vitor Rename var libavcodec
Thu, 12 Jun 2008 21:50:13 +0000 stefano Make AVCodec long_names definition conditional depending on CONFIG_SMALL. libavcodec
Thu, 05 Jun 2008 16:15:44 +0000 vitor Remove *lpc_refl from the context. Only the value libavcodec
Thu, 05 Jun 2008 16:11:51 +0000 vitor Split function rms() in two (it does two unrelated things) libavcodec
Mon, 02 Jun 2008 18:29:04 +0000 vitor Remove warning that could never be triggered. libavcodec
Sun, 01 Jun 2008 19:51:33 +0000 vitor Replace comments by error messages. libavcodec
Sun, 01 Jun 2008 19:36:54 +0000 vitor Cosmetics libavcodec
Sun, 01 Jun 2008 19:36:43 +0000 vitor Rename dec2() function libavcodec
Sun, 01 Jun 2008 19:35:04 +0000 vitor Rename var libavcodec
Sun, 01 Jun 2008 19:33:17 +0000 vitor Rename dec1() to a more descriptive name libavcodec
Sun, 01 Jun 2008 19:30:07 +0000 vitor The function dec1() do two completly unrelated things. Split the rms calculation out of it. libavcodec
Sun, 01 Jun 2008 13:30:15 +0000 vitor Yet more variable renaming libavcodec
Sun, 01 Jun 2008 13:28:41 +0000 vitor More variable renaming libavcodec
Sun, 01 Jun 2008 13:17:22 +0000 vitor Rename functions libavcodec
Sun, 01 Jun 2008 13:16:13 +0000 vitor Rename variables libavcodec
Sat, 31 May 2008 15:37:41 +0000 vitor Add doxy comments to eq() and do_voice() libavcodec
Sat, 31 May 2008 14:38:34 +0000 vitor Minor simplification libavcodec
Sat, 31 May 2008 14:36:46 +0000 vitor Rename variable libavcodec
Sat, 31 May 2008 14:34:35 +0000 vitor Remove useless intermediate variable libavcodec
Fri, 30 May 2008 19:46:43 +0000 vitor Revert r13499, log: libavcodec
Wed, 28 May 2008 21:25:18 +0000 vitor Rename variable libavcodec
Wed, 28 May 2008 21:17:32 +0000 vitor More intermediate vars removal libavcodec
Wed, 28 May 2008 21:04:42 +0000 vitor Remove unused var libavcodec
Wed, 28 May 2008 21:02:51 +0000 vitor Remove useless intermediate var libavcodec
Wed, 28 May 2008 20:36:11 +0000 vitor Remove dec1() function libavcodec
Wed, 28 May 2008 19:04:34 +0000 vitor Use ff_acelp_weighted_vector_sum() instead of reimplementing it libavcodec
Wed, 28 May 2008 19:02:16 +0000 vitor Make lpc coefficients 16 bit wide libavcodec
Wed, 28 May 2008 18:59:09 +0000 vitor Simplify implementation and use of dec2() libavcodec
Tue, 27 May 2008 16:50:48 +0000 vitor Add comment libavcodec
Tue, 27 May 2008 16:14:31 +0000 vitor Fix doxy comments libavcodec
Tue, 27 May 2008 10:51:23 +0000 diego cosmetics: typo fixes libavcodec
Mon, 26 May 2008 23:11:24 +0000 diego cosmetics: typo libavcodec
Mon, 26 May 2008 18:26:47 +0000 vitor Rename var: add read coefficients a decent name libavcodec
Mon, 26 May 2008 18:21:09 +0000 vitor Update comment libavcodec
Mon, 26 May 2008 18:18:33 +0000 vitor Rename var: val -> energy libavcodec
Mon, 26 May 2008 18:16:05 +0000 vitor Rename var: swapbuf* are LPC related libavcodec
Mon, 26 May 2008 17:10:00 +0000 vitor Rename var: buffer_2 is an adaptive codebook libavcodec
Mon, 26 May 2008 16:59:39 +0000 vitor Context vars are not global vars. glob is a bad name for it. libavcodec
Mon, 26 May 2008 16:55:22 +0000 vitor Rename context struct to be more consistent with the rest of ffmpeg libavcodec
Sun, 25 May 2008 19:48:03 +0000 vitor Merge two if's libavcodec
Sun, 25 May 2008 19:00:13 +0000 vitor Use (u)int16_t instead of (unsigned) short libavcodec
Sun, 25 May 2008 17:04:42 +0000 vitor More cosmetics libavcodec
Sun, 25 May 2008 16:58:25 +0000 vitor Cosmetics libavcodec