log ra288.c @ 7451:85ab7655ad4d libavcodec

age author description
Thu, 31 Jul 2008 10:47:31 +0000 pross Modify all codecs to report their supported input and output sample format(s). libavcodec
Tue, 29 Jul 2008 18:22:31 +0000 vitor Do not declare a counter as unsigned when it is not needed libavcodec
Tue, 29 Jul 2008 18:20:49 +0000 vitor Cosmetics: rename loop counter vars to i,j libavcodec
Mon, 28 Jul 2008 10:49:44 +0000 vitor Cosmetics: new line libavcodec
Mon, 28 Jul 2008 10:49:14 +0000 vitor Remove the now useless phase variable from context libavcodec
Mon, 28 Jul 2008 05:18:39 +0000 vitor Cosmetics: make comment match var name libavcodec
Mon, 28 Jul 2008 05:16:51 +0000 vitor Cosmetics: align comments libavcodec
Mon, 28 Jul 2008 04:53:05 +0000 vitor Rename two context vars: s/sb/sp_block/, s/lhist/gain_block/ libavcodec
Mon, 28 Jul 2008 04:37:58 +0000 vitor Declare temporary buffers to be only of the necessary size libavcodec
Mon, 28 Jul 2008 04:25:51 +0000 vitor Remove redundant comments libavcodec
Mon, 28 Jul 2008 04:24:08 +0000 vitor Cosmetics: do not align with now removed next instruction libavcodec
Mon, 28 Jul 2008 04:07:18 +0000 vitor Cosmetics: remove braces and useless newline libavcodec
Mon, 28 Jul 2008 02:55:47 +0000 vitor Change the way the input is passed to do_hybrid_filter(). Before, in[0] was libavcodec
Mon, 28 Jul 2008 02:53:07 +0000 vitor Remove RA288Context.output buffer. This buffer is just RA288Context.sb libavcodec
Sun, 27 Jul 2008 22:22:51 +0000 vitor Add a few comments pointing to the G.728 specification libavcodec
Sun, 27 Jul 2008 22:21:41 +0000 vitor Remove the history buffer from the context. It can easily be evaluated libavcodec
Sun, 27 Jul 2008 20:58:29 +0000 vitor Rename two context buffers: pr{1,2} -> {sp,gain}_lpc. Also add a few doxy libavcodec
Sun, 27 Jul 2008 20:55:27 +0000 vitor Remove st1 and st2 temporary buffers in backward_filter() and use instead libavcodec
Sun, 27 Jul 2008 20:35:32 +0000 vitor Change slightly the meaning of RA288Context.phase. This libavcodec
Sat, 26 Jul 2008 15:14:50 +0000 vitor Remove st1 and st2 variables from context, since they could be just local vars libavcodec
Sat, 26 Jul 2008 15:10:17 +0000 vitor Rename st{1,2}{a,b} context variables to more meaningful names: {sp,gain}_{rec,hist} libavcodec
Sat, 26 Jul 2008 14:38:29 +0000 vitor Cosmetics: remove useless parenthesis libavcodec
Sat, 26 Jul 2008 14:35:50 +0000 vitor Move colmult() function to the beginning of file to group DSP-related functions. libavcodec
Sat, 26 Jul 2008 14:33:53 +0000 vitor Remove an useless comment describing colmult() libavcodec
Sat, 26 Jul 2008 14:33:25 +0000 vitor Remove an useless comment describing prodsum() libavcodec
Sat, 26 Jul 2008 14:31:47 +0000 vitor Give the context variables of ra288 a better name: s/glob/ractx/ libavcodec
Sat, 26 Jul 2008 14:29:39 +0000 vitor Give the context structure of ra288 a better name: s/Real288_internal/RA288Context/ libavcodec
Thu, 24 Jul 2008 11:55:01 +0000 vitor Cosmetics: grammar nits libavcodec
Thu, 24 Jul 2008 04:29:23 +0000 vitor Rename update() function to backward_filter() and add a doxy comment libavcodec
Thu, 24 Jul 2008 04:15:50 +0000 vitor Rename and comment bandwidth broadening tables libavcodec
Thu, 24 Jul 2008 04:07:50 +0000 vitor Follow FFmpeg convention of returning negative values on error in eval_lpc_coeffs() libavcodec
Thu, 24 Jul 2008 04:05:41 +0000 vitor Rename pred() to eval_lpc_coeffs() and add a doxy comment libavcodec
Thu, 24 Jul 2008 03:50:06 +0000 vitor Give windowing tables a more descriptive name libavcodec
Thu, 24 Jul 2008 03:28:42 +0000 vitor Add comments to do_hybrid_window() libavcodec
Thu, 24 Jul 2008 03:28:01 +0000 vitor Give parameters of do_hybrid_window() more meaningful names libavcodec
Thu, 24 Jul 2008 03:23:51 +0000 vitor Rename co() function to the much more descriptive name of libavcodec
Thu, 24 Jul 2008 03:22:19 +0000 vitor Simplify co(): write constant in a more readable way libavcodec
Thu, 24 Jul 2008 03:19:52 +0000 vitor Simplify co(), use memcpy/memmove and colmult() when useful. libavcodec
Sat, 19 Jul 2008 15:43:34 +0000 vitor Cosmetics: alignment libavcodec
Sat, 19 Jul 2008 15:41:15 +0000 vitor Simplify co(): do not abuse pointer aritmetics libavcodec
Sat, 19 Jul 2008 15:32:29 +0000 vitor Simplify co(): remove variables that are only used once libavcodec
Thu, 17 Jul 2008 23:48:53 +0000 vitor Simplify: do not overuse pointer aritmetic libavcodec
Thu, 17 Jul 2008 23:02:52 +0000 vitor Declare parameters of pred() that could be const as such libavcodec
Thu, 17 Jul 2008 23:01:31 +0000 vitor Another simplification libavcodec
Thu, 17 Jul 2008 22:59:53 +0000 vitor Simplify libavcodec
Thu, 17 Jul 2008 22:42:21 +0000 vitor Simplify libavcodec
Thu, 17 Jul 2008 22:39:29 +0000 vitor Declare function parameters as const libavcodec
Mon, 14 Jul 2008 14:41:01 +0000 vitor Revert r14218. FFMAX is a macro, so libavcodec
Sun, 13 Jul 2008 20:41:09 +0000 vitor Simplify libavcodec
Sun, 13 Jul 2008 20:39:55 +0000 vitor Another av_clipf() usage libavcodec
Sun, 13 Jul 2008 20:38:42 +0000 vitor Do not declare as double a var that only stores a float libavcodec
Sun, 13 Jul 2008 20:36:32 +0000 vitor Simplify: use FFMAX libavcodec
Sun, 13 Jul 2008 19:59:44 +0000 vitor Add av_clipf() function to common.h and use it in ra288.c libavcodec
Sun, 06 Jul 2008 14:23:30 +0000 vitor Simplify: glob->phase is always == 3 libavcodec
Sun, 06 Jul 2008 12:03:21 +0000 vitor Remove phasep context var, it is just phase*5 libavcodec
Sun, 06 Jul 2008 12:01:59 +0000 vitor Slighly faster operation libavcodec
Sun, 06 Jul 2008 10:35:01 +0000 vitor Cosmetics: remove braces libavcodec
Sun, 06 Jul 2008 10:32:29 +0000 vitor Another use of scalar_product_float() libavcodec
Sun, 06 Jul 2008 10:30:21 +0000 vitor Do not reimplement memmove() libavcodec
Sat, 05 Jul 2008 18:43:24 +0000 vitor Cosmetics: remove braces libavcodec