2008-07-25 |
michael |
10000l, forgotton }
libavcodec
|
2008-07-25 |
michael |
Remove another of these obfuscated special cases for field pictures
libavcodec
|
2008-07-25 |
michael |
Simplify mmco setup code used in IDR pictures.
libavcodec
|
2008-07-25 |
michael |
Remove redundant h->mmco_index= 0.
libavcodec
|
2008-07-25 |
michael |
Assert that long_ref has been cleared for released pics.
libavcodec
|
2008-07-25 |
michael |
Clear long_ref when a frame is no longer a long_ref.
libavcodec
|
2008-07-25 |
michael |
Make sure mmco index is 0 (instead of uninitialized) in all error returns.
libavcodec
|
2008-07-25 |
michael |
Simplify strange obfuscated code in MMCO_LONG handling.
libavcodec
|
2008-07-24 |
michael |
Set field_poc (it was half uninitialized before) and use it
libavcodec
|
2008-07-24 |
michael |
Minor simplification of code in init_poc().
libavcodec
|
2008-07-24 |
michael |
cosmetics (indent and 2 empty lines)
libavcodec
|
2008-07-24 |
michael |
init_poc() vs. idr() cleanup
libavcodec
|
2008-07-24 |
michael |
Fix loop filter with CAVLC 8x8dct.
libavcodec
|
2008-07-24 |
diego |
cosmetics: Fix two common typos: wont --> will not, lets --> let us.
libavcodec
|
2008-07-24 |
diego |
cosmetics: Fix indentation after last commit.
libavcodec
|
2008-07-24 |
vitor |
Cosmetics: grammar nits
libavcodec
|
2008-07-24 |
diego |
misc spelling/grammar fixes
libavcodec
|
2008-07-24 |
diego |
Remove AltiVec vector declaration compiler compatibility macros.
libavcodec
|
2008-07-24 |
vitor |
Rename update() function to backward_filter() and add a doxy comment
libavcodec
|
2008-07-24 |
vitor |
Rename and comment bandwidth broadening tables
libavcodec
|
2008-07-24 |
vitor |
Follow FFmpeg convention of returning negative values on error in eval_lpc_coeffs()
libavcodec
|
2008-07-24 |
vitor |
Rename pred() to eval_lpc_coeffs() and add a doxy comment
libavcodec
|
2008-07-24 |
vitor |
Give windowing tables a more descriptive name
libavcodec
|
2008-07-24 |
vitor |
Add comments to do_hybrid_window()
libavcodec
|
2008-07-24 |
vitor |
Give parameters of do_hybrid_window() more meaningful names
libavcodec
|
2008-07-24 |
vitor |
Rename co() function to the much more descriptive name of
libavcodec
|
2008-07-24 |
vitor |
Simplify co(): write constant in a more readable way
libavcodec
|
2008-07-24 |
vitor |
Simplify co(), use memcpy/memmove and colmult() when useful.
libavcodec
|