Wed, 02 Jul 2008 22:25:17 +0000 |
astrange |
Use get_cabac_bypass_sign instead of an if/else.
libavcodec
|
Wed, 02 Jul 2008 22:20:06 +0000 |
astrange |
Reorder the if/else for residual cats to match gcc's branch prediction.
libavcodec
|
Wed, 02 Jul 2008 22:15:05 +0000 |
astrange |
Simplify loop condition for readability.
libavcodec
|
Wed, 02 Jul 2008 22:12:01 +0000 |
astrange |
Reindent.
libavcodec
|
Wed, 02 Jul 2008 22:08:12 +0000 |
astrange |
Clone decode_cabac_residual() for DC residuals, to get rid of a bunch of branches in the main loop.
libavcodec
|
Wed, 02 Jul 2008 22:03:53 +0000 |
astrange |
Don't generate two copies of hl_decode_mb() under ENABLE_SMALL.
libavcodec
|
Wed, 02 Jul 2008 21:46:18 +0000 |
astrange |
Don't test for H264 encoding unless an encoder exists.
libavcodec
|
Wed, 02 Jul 2008 12:24:50 +0000 |
ramiro |
Clarify comment about parity nibble.
libavcodec
|
Tue, 01 Jul 2008 01:36:16 +0000 |
ramiro |
Make ff_mlp_read_major_sync() take a GetBitContext instead of buffers.
libavcodec
|
Mon, 30 Jun 2008 21:46:49 +0000 |
stefano |
Clarify/simplify documentation for the default_val field in AVOption.
libavcodec
|
Mon, 30 Jun 2008 19:30:27 +0000 |
vitor |
Remove useless wrapper around ra288_decode_frame()
libavcodec
|
Mon, 30 Jun 2008 19:09:00 +0000 |
vitor |
Remove unpack() function, read the bitstream as needed
libavcodec
|
Mon, 30 Jun 2008 18:39:11 +0000 |
vitor |
Clean up error message
libavcodec
|
Mon, 30 Jun 2008 18:36:45 +0000 |
vitor |
Rewrite unpack() using the bitstream reader
libavcodec
|
Mon, 30 Jun 2008 18:03:38 +0000 |
voroshil |
gain code, gain pitch and pitch delay decoding for ACELP based codecs
libavcodec
|
Mon, 30 Jun 2008 16:57:27 +0000 |
vitor |
Move function to avoid forward declaration
libavcodec
|
Mon, 30 Jun 2008 16:54:49 +0000 |
vitor |
Remove useless initialization
libavcodec
|
Mon, 30 Jun 2008 16:53:33 +0000 |
vitor |
Reindent the whole file
libavcodec
|
Mon, 30 Jun 2008 11:16:47 +0000 |
benoit |
Simplify mm_support() for ARM (by Mns).
libavcodec
|
Mon, 30 Jun 2008 07:31:41 +0000 |
benoit |
Define mm_support() for ARM.
libavcodec
|
Sun, 29 Jun 2008 21:37:03 +0000 |
vitor |
Make ff_acelp_lp_synthesis_filter() receives a pointer to the actual filter coefficients and not the pointer minus one
libavcodec
|
Sun, 29 Jun 2008 13:12:31 +0000 |
vitor |
Update copyright
libavcodec
|
Sun, 29 Jun 2008 11:21:06 +0000 |
vitor |
Use ff_acelp_lp_synthesis_filter() instead of duplicating it
libavcodec
|
Sun, 29 Jun 2008 11:19:50 +0000 |
vitor |
Add a rounding parameter to ff_acelp_lp_synthesis_filter()
libavcodec
|