diff imgutils.c @ 18:ebe3b7ce4cca libavcore

Rename av_fill_image_max_pixstep() to av_fill_image_max_pixsteps(). The plural form is preferred as it is more consistent with the other functions: av_fill_image_linesizes() av_fill_image_pointers() and looks semantically more correct as it fills an array of elements.
author stefano
date Fri, 20 Aug 2010 16:52:38 +0000
parents 1a1faa090ff1
children cee2ee2eff81
line wrap: on
line diff
--- a/imgutils.c	Fri Aug 20 16:34:41 2010 +0000
+++ b/imgutils.c	Fri Aug 20 16:52:38 2010 +0000
@@ -34,7 +34,7 @@
     if (desc->flags & PIX_FMT_BITSTREAM)
         return (width * (desc->comp[0].step_minus1+1) + 7) >> 3;
 
-    av_fill_image_max_pixstep(max_step, max_step_comp, desc);
+    av_fill_image_max_pixsteps(max_step, max_step_comp, desc);
     s = (max_step_comp[plane] == 1 || max_step_comp[plane] == 2) ? desc->log2_chroma_w : 0;
     return max_step[plane] * (((width + (1 << s) - 1)) >> s);
 }
@@ -56,7 +56,7 @@
         return 0;
     }
 
-    av_fill_image_max_pixstep(max_step, max_step_comp, desc);
+    av_fill_image_max_pixsteps(max_step, max_step_comp, desc);
     for (i = 0; i < 4; i++) {
         int s = (max_step_comp[i] == 1 || max_step_comp[i] == 2) ? desc->log2_chroma_w : 0;
         linesizes[i] = max_step[i] * (((width + (1 << s) - 1)) >> s);