diff mpegenc.c @ 4873:1800b33b2c15 libavformat

Rename pbBufPtr() to put_bits_ptr(). The new name is more readable and consistent with the FFmpeg naming style.
author stefano
date Mon, 13 Apr 2009 16:59:38 +0000
parents 7aa7c5853bb6
children 67974323f1cf
line wrap: on
line diff
--- a/mpegenc.c	Mon Apr 13 16:20:26 2009 +0000
+++ b/mpegenc.c	Mon Apr 13 16:59:38 2009 +0000
@@ -114,7 +114,7 @@
         put_bits(&pb, 3, 0); /* stuffing length */
     }
     flush_put_bits(&pb);
-    return pbBufPtr(&pb) - pb.buf;
+    return put_bits_ptr(&pb) - pb.buf;
 }
 
 static int put_system_header(AVFormatContext *ctx, uint8_t *buf,int only_for_stream_id)
@@ -256,7 +256,7 @@
     }
 
     flush_put_bits(&pb);
-    size = pbBufPtr(&pb) - pb.buf;
+    size = put_bits_ptr(&pb) - pb.buf;
     /* patch packet size */
     buf[4] = (size - 6) >> 8;
     buf[5] = (size - 6) & 0xff;