comparison pixdesc.c @ 982:da1b5110dbd0 libavutil

Rename read/write_line() to av_read/write_image_line(). The old names were not av_ prefixed, and they were causing linking failure on many platforms. The new names are also more descriptive. Patch by Stefano Sabatini.
author mru
date Wed, 07 Jul 2010 23:41:42 +0000
parents 9087f43dbcd2
children f2fa8ffe7a05
comparison
equal deleted inserted replaced
981:d004c9e2aa40 982:da1b5110dbd0
22 #include "pixfmt.h" 22 #include "pixfmt.h"
23 #include "pixdesc.h" 23 #include "pixdesc.h"
24 24
25 #include "intreadwrite.h" 25 #include "intreadwrite.h"
26 26
27 void read_line(uint16_t *dst, const uint8_t *data[4], const int linesize[4], 27 void av_read_image_line(uint16_t *dst, const uint8_t *data[4], const int linesize[4],
28 const AVPixFmtDescriptor *desc, int x, int y, int c, int w, int read_pal_component) 28 const AVPixFmtDescriptor *desc, int x, int y, int c, int w, int read_pal_component)
29 { 29 {
30 AVComponentDescriptor comp= desc->comp[c]; 30 AVComponentDescriptor comp= desc->comp[c];
31 int plane= comp.plane; 31 int plane= comp.plane;
32 int depth= comp.depth_minus1+1; 32 int depth= comp.depth_minus1+1;
63 *dst++= val; 63 *dst++= val;
64 } 64 }
65 } 65 }
66 } 66 }
67 67
68 void write_line(const uint16_t *src, uint8_t *data[4], const int linesize[4], 68 void av_write_image_line(const uint16_t *src, uint8_t *data[4], const int linesize[4],
69 const AVPixFmtDescriptor *desc, int x, int y, int c, int w) 69 const AVPixFmtDescriptor *desc, int x, int y, int c, int w)
70 { 70 {
71 AVComponentDescriptor comp = desc->comp[c]; 71 AVComponentDescriptor comp = desc->comp[c];
72 int plane = comp.plane; 72 int plane = comp.plane;
73 int depth = comp.depth_minus1+1; 73 int depth = comp.depth_minus1+1;