Sat, 13 Jan 2007 04:01:35 +0000 |
diego |
Avoid "HAVE_CMOV not defined" warning.
libavutil
|
Fri, 08 Dec 2006 00:35:08 +0000 |
mru |
rename always_inline to av_always_inline and move to common.h
libavutil
|
Thu, 07 Dec 2006 20:06:11 +0000 |
mru |
merge #ifdef HAVE_AV_CONFIG_H sections
libavutil
|
Thu, 07 Dec 2006 19:27:00 +0000 |
mru |
fix mingw shared build, and get rid of FF_IMPORT_ATTR
libavutil
|
Wed, 06 Dec 2006 23:46:11 +0000 |
mru |
use the standard INT64_C() macro for 64-bit constants
libavutil
|
Wed, 06 Dec 2006 23:23:20 +0000 |
mru |
move more macros to internal.h
libavutil
|
Wed, 06 Dec 2006 21:27:08 +0000 |
mru |
move some __attribute__ macros to internal.h
libavutil
|
Wed, 06 Dec 2006 20:31:39 +0000 |
mru |
remove 'restrict' definition, it is always #defined in config.h
libavutil
|
Sat, 02 Dec 2006 14:19:49 +0000 |
diego |
spelling cosmetics: cliped --> clipped
libavutil
|
Sun, 19 Nov 2006 09:43:26 +0000 |
reimar |
Correct GET/PUT_UTF8 comment: the get/put functions might be called up
libavutil
|
Sun, 19 Nov 2006 09:33:50 +0000 |
reimar |
Fix typo in comment
libavutil
|
Tue, 14 Nov 2006 20:00:55 +0000 |
mru |
remove workaround for missing inttypes.h
libavutil
|
Tue, 14 Nov 2006 04:02:58 +0000 |
mru |
clean up inttypes.h and int_fastxx_t types detection
libavutil
|
Mon, 06 Nov 2006 12:38:00 +0000 |
gpoirier |
Add doxy comments for macro GET_UTF8
libavutil
|
Mon, 06 Nov 2006 10:39:07 +0000 |
gpoirier |
Fix wrong params name in PUT_UTF8 doxy comments
libavutil
|
Mon, 06 Nov 2006 10:35:54 +0000 |
gpoirier |
woops, fix missplaced doxy comment
libavutil
|
Mon, 06 Nov 2006 10:32:48 +0000 |
gpoirier |
Fix ASF format parser's broken UTF-16 string handling
libavutil
|
Wed, 01 Nov 2006 22:37:56 +0000 |
diego |
Define fallback for PRIX64, taken from a patch by Steve L'Homme.
libavutil
|
Wed, 01 Nov 2006 21:28:36 +0000 |
diego |
Rename SWAP macro to FFSWAP.
libavutil
|
Wed, 01 Nov 2006 18:34:40 +0000 |
diego |
Use common define for x86_32 and x86_64.
libavutil
|
Wed, 01 Nov 2006 17:01:33 +0000 |
diego |
Add ARCH_X86_32 as a new define for 32 bit x86 architectures and change
libavutil
|
Fri, 20 Oct 2006 17:53:19 +0000 |
gpoirier |
Protect code that uses CMOV instructions with HAVE_CMOV,
libavutil
|
Wed, 11 Oct 2006 23:17:58 +0000 |
diego |
Rename ABS macro to FFABS.
libavutil
|
Wed, 11 Oct 2006 22:59:37 +0000 |
diego |
Rename SIGN macro to FFSIGN to avoid clashes with system headers.
libavutil
|
Tue, 10 Oct 2006 07:49:10 +0000 |
diego |
Move sign macro to libavutil.
libavutil
|
Sat, 07 Oct 2006 15:30:46 +0000 |
diego |
Change license headers to say 'FFmpeg' instead of 'this program/this library'
libavutil
|
Mon, 25 Sep 2006 15:23:40 +0000 |
lu_zero |
move memory functions from avcodec to avutil
libavutil
|
Thu, 21 Sep 2006 18:00:05 +0000 |
lorenm |
remove a division from STOP_TIMER
libavutil
|
Thu, 21 Sep 2006 17:48:45 +0000 |
lorenm |
simplify asm mid_pred, as suggested by michaelni.
libavutil
|
Fri, 15 Sep 2006 00:36:49 +0000 |
lorenm |
asm implementation of mid_pred.
libavutil
|