diff dvdread/Makefile.am @ 307:5039307a3e7c src

dvdread is now built as independent library and installed system-wide alongside libdvdnav (it's intended to be a replacement for ogle's dvdread that is broken)
author nicodvb
date Sun, 05 Aug 2007 20:27:59 +0000
parents b4f9a592bc84
children 34edc5cf014f
line wrap: on
line diff
--- a/dvdread/Makefile.am	Thu Aug 02 21:58:59 2007 +0000
+++ b/dvdread/Makefile.am	Sun Aug 05 20:27:59 2007 +0000
@@ -1,10 +1,10 @@
 include $(top_srcdir)/misc/Makefile.common
 
-includedir = ${prefix}/include/dvdnav
+includedir = ${prefix}/include/dvdread
 
 AM_CPPFLAGS = -DDVDNAV_COMPILE -I$(top_srcdir)/src/vm
 
-noinst_LTLIBRARIES = libdvdread.la
+lib_LTLIBRARIES = libdvdread.la
 
 libdvdread_la_SOURCES = dvd_reader.c nav_read.c ifo_read.c \
 	dvd_input.c dvd_udf.c md5.c nav_print.c ifo_print.c \
@@ -12,5 +12,8 @@
 
 libdvdread_la_LIBADD = $(DYNAMIC_LD_LIBS)
 
+libdvdread_la_LDFLAGS = -version-info $(DVDNAV_LT_CURRENT):$(DVDNAV_LT_REVISION):$(DVDNAV_LT_AGE) \
+	-export-symbols-regex "(^dvd.*|^nav.*|^ifo.*|^DVD.*)"
+
 include_HEADERS = dvd_reader.h nav_read.h ifo_read.h \
 	nav_print.h ifo_print.h ifo_types.h nav_types.h