diff dvdread/Makefile.am @ 225:9b1b740e3fc9 src

big build system changes * cleaned up all Makefiles and added a Makefile.common * added relchk script * moved libdvdread files to a dvdread subdir * moved DVD VM to a vm subdir * removed unused code in read_cache.c
author mroi
date Sun, 11 Jan 2004 21:43:13 +0000
parents
children 59b5753b09d7
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/dvdread/Makefile.am	Sun Jan 11 21:43:13 2004 +0000
@@ -0,0 +1,17 @@
+include $(top_srcdir)/misc/Makefile.common
+
+includedir = ${prefix}/include/dvdnav
+
+AM_CPPFLAGS = -DDVDNAV_COMPILE -I$(top_srcdir)/src/vm
+
+noinst_LTLIBRARIES = libdvdread.la
+
+libdvdread_la_SOURCES = dvd_reader.c nav_read.c ifo_read.c \
+	dvd_input.c dvd_udf.c md5.c nav_print.c ifo_print.c
+
+libdvdread_la_LIBADD = $(DYNAMIC_LD_LIBS)
+
+include_HEADERS = dvd_reader.h nav_read.h ifo_read.h \
+	nav_print.h ifo_print.h ifo_types.h nav_types.h
+
+noinst_HEADERS = bswap.h dvd_input.h dvdread_internal.h dvd_udf.h md5.h