diff Makefile.am @ 395:9c5aef10d165 src

Move dvd_types.h, dvdnav_events.h and dvdnav.h into a dvdnav directory. This allows getting rid of the DVDNAV_COMPILE define hack and makes it easier to use the library without installing or integrating the source into some other project directly.
author reimar
date Tue, 30 Dec 2008 14:48:46 +0000
parents 04e184087151
children
line wrap: on
line diff
--- a/Makefile.am	Thu Oct 09 22:20:36 2008 +0000
+++ b/Makefile.am	Tue Dec 30 14:48:46 2008 +0000
@@ -4,7 +4,7 @@
 
 includedir = ${prefix}/include/dvdnav
 
-AM_CPPFLAGS = -DDVDNAV_COMPILE $(THREAD_CFLAGS) $(DVDREAD_CFLAGS) \
+AM_CPPFLAGS = $(THREAD_CFLAGS) $(DVDREAD_CFLAGS) \
 	-I$(top_srcdir)/src/vm
 
 EXTRA_DIST = README.MAP FELLOWSHIP.map
@@ -31,4 +31,4 @@
 
 libdvdnavmini_la_LDFLAGS = $(libdvdnav_la_LDFLAGS)
 
-include_HEADERS = dvdnav.h dvdnav_events.h dvd_types.h
+include_HEADERS = dvdnav/dvdnav.h dvdnav/dvdnav_events.h dvdnav/dvd_types.h