comparison debian/rules @ 4521:0737156ad1f0

Juergen Kreileder changes, fixing some lintian errors, adding correct manpath and adding xvidix to array of system-selectable drivers.
author eyck
date Sun, 03 Feb 2002 20:27:20 +0000
parents a77ce64a7066
children 769ed0711b48
comparison
equal deleted inserted replaced
4520:0dca90717403 4521:0737156ad1f0
4 #export DH_VERBOSE=1 4 #export DH_VERBOSE=1
5 # This is the debhelper compatability version to use. 5 # This is the debhelper compatability version to use.
6 export DH_COMPAT=3 6 export DH_COMPAT=3
7 7
8 package := mplayer 8 package := mplayer
9 prefix := debian/$(package) 9 prefix := $(shell pwd)/debian/$(package)
10
10 arch := $(shell dpkg --print-architecture) 11 arch := $(shell dpkg --print-architecture)
11 12
12 ifeq ($(arch),powerpc) 13 ifeq ($(arch),powerpc)
13 arch-conf += --disable-mp1e 14 arch-conf += --disable-mp1e
14 endif 15 endif
51 dh_testroot 52 dh_testroot
52 dh_clean -k 53 dh_clean -k
53 dh_installdirs 54 dh_installdirs
54 55
55 # commands to install the package into debian/<packagename> 56 # commands to install the package into debian/<packagename>
56 $(MAKE) prefix=$(prefix)/usr CONFDIR=$(prefix)/etc/mplayer DATADIR=$(prefix)/usr/share/mplayer install 57 $(MAKE) prefix=$(prefix)/usr CONFDIR=$(prefix)/etc/mplayer DATADIR=$(prefix)/usr/share/mplayer MANDIR=$(prefix)/usr/share/man install
57 dh_link usr/bin/mplayer usr/bin/gmplayer 58 dh_link usr/bin/mplayer usr/bin/gmplayer \
59 usr/share/man/man1/mplayer.1.gz usr/share/man/man1/gmplayer.1.gz
60
58 61
59 dh_installdebconf 62 dh_installdebconf
60 dh_installdocs DOCS/* 63 dh_installdocs DOCS/*
61 dh_installexamples etc/example.conf 64 dh_installexamples etc/example.conf
62 dh_installmenu 65 dh_installmenu