comparison debian/rules @ 18:531d58007138

Initial revision
author arpi_esp
date Tue, 27 Feb 2001 02:04:08 +0000
parents
children 82bd5187d6d8
comparison
equal deleted inserted replaced
17:4e5d445520d9 18:531d58007138
1 #!/usr/bin/make -f
2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
4
5 package=mplayer
6
7 build:
8 $(checkdir)
9 ./setup.sh
10 ./configure --prefix=/usr `cat setup.s`
11 make dep
12 make
13 touch build
14
15 clean:
16 $(checkdir)
17 -rm -f build
18 -$(MAKE) distclean
19 -rm -f `find . -name "*~"`
20 -rm -rf debian/tmp debian/files* core debian/substvars
21
22 binary-indep: checkroot build
23 $(checkdir)
24 # There are no architecture-independent files to be uploaded
25 # generated by this package. If there were any they would be
26 # made here.
27
28 binary-arch: checkroot build
29 $(checkdir)
30 -rm -rf debian/tmp
31 install -d debian/tmp
32 cd debian/tmp && install -d `cat ../dirs`
33 $(MAKE) install prefix=`pwd`/debian/tmp/usr
34 # Must have debmake installed for this to work. Otherwise please copy
35 # /usr/bin/debstd into the debian directory and change debstd to debian/debstd
36 debstd
37 dpkg-gencontrol -isp
38 chown -R root.root debian/tmp
39 chmod -R go=rX debian/tmp
40 dpkg --build debian/tmp ..
41
42 define checkdir
43 test -f debian/rules
44 endef
45
46 binary: binary-indep binary-arch
47
48 checkroot:
49 $(checkdir)
50 test root = "`whoami`"
51
52 .PHONY: binary binary-arch binary-indep clean checkroot