comparison debian/rules @ 3974:90e7917f945f

Clean up - no longer needed comments, commented out older version of solutions.
author eyck
date Fri, 04 Jan 2002 10:39:51 +0000
parents b30ffe58ff18
children 8d60da7c4ac6
comparison
equal deleted inserted replaced
3973:138800dfbe22 3974:90e7917f945f
1 #!/usr/bin/make -f 1 #!/usr/bin/make -f
2 # Made with the aid of debmake, by Christoph Lameter, 2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson. 3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
4 #export DH_VERBOSE=1 4 #export DH_VERBOSE=1
5 # This is the debhelper compatability version to use. 5 # This is the debhelper compatability version to use.
6 export DH_COMPAT=2 6 export DH_COMPAT=3
7 7
8 package := mplayer 8 package := mplayer
9 prefix := debian/$(package) 9 prefix := debian/$(package)
10 arch := $(shell dpkg --print-architecture) 10 arch := $(shell dpkg --print-architecture)
11 11
52 dh_clean -k 52 dh_clean -k
53 dh_installdirs 53 dh_installdirs
54 54
55 # commands to install the package into debian/<packagename> 55 # commands to install the package into debian/<packagename>
56 $(MAKE) prefix=$(prefix)/usr CONFDIR=$(prefix)/usr/share/mplayer DATADIR=$(prefix)/usr/share/mplayer install 56 $(MAKE) prefix=$(prefix)/usr CONFDIR=$(prefix)/usr/share/mplayer DATADIR=$(prefix)/usr/share/mplayer install
57 #install -m 755 -s mplayer $(CURDIR)/debian/`dh_listpackages`/usr/bin/mplayer
58 dh_link usr/bin/mplayer usr/bin/gmplayer 57 dh_link usr/bin/mplayer usr/bin/gmplayer
59 #install -o root -g root -m 0644 etc/codecs.conf $(prefix)/usr/share/mplayer
60 58
61 dh_installdebconf 59 dh_installdebconf
62 dh_installdocs DOCS/* 60 dh_installdocs DOCS/*
63 dh_installexamples etc/example.conf 61 dh_installexamples etc/example.conf
64 dh_installmenu 62 dh_installmenu
65 # dh_installmime 63 # dh_installmime
66 # dh_installmanpages TVout/fbset/fb.modes.5 TVout/fbset/fbset.8
67 # dh_installmanpages # handled by make install above
68 dh_installinfo 64 dh_installinfo
69 # dh_undocumented
70 dh_installchangelogs 65 dh_installchangelogs
71 dh_link 66 dh_link
72 dh_strip 67 dh_strip
73 dh_compress 68 dh_compress
74 dh_fixperms 69 dh_fixperms