comparison debian/rules @ 29427:ba2cb7c23fa2

dpkg-buildpackage automatically sets CFLAGS and pals to -g -O2. Unset CFLAGS and friends to avoid failures when building Debian packages. patch from the official Debian package, submitted by Anton Khirnov
author diego
date Sun, 02 Aug 2009 15:17:26 +0000
parents 0f1b5b68af32
children
comparison
equal deleted inserted replaced
29426:1cedde378788 29427:ba2cb7c23fa2
8 package := mplayer 8 package := mplayer
9 prefix := $(shell pwd)/debian/$(package) 9 prefix := $(shell pwd)/debian/$(package)
10 10
11 arch := $(shell dpkg --print-architecture) 11 arch := $(shell dpkg --print-architecture)
12 12
13 # See http://wiki.debian.org/Teams/Dpkg/DebianRules; #465282 and
14 # https://wiki.ubuntu.com/DistCompilerFlags
15 CLEAN_ENV=env -u CFLAGS -u CPPFLAGS -u LDFLAGS -u FFLAGS -u CXXFLAGS
13 16
14 configure: configure-stamp 17 configure: configure-stamp
15 configure-stamp: 18 configure-stamp:
16 dh_testdir 19 dh_testdir
17 # Add here commands to configure the package. 20 # Add here commands to configure the package.
18 $(checkdir) 21 $(checkdir)
19 # If you plan to install the target .deb on a wide variety of machines, 22 # If you plan to install the target .deb on a wide variety of machines,
20 # you may want to add the "--enable-runtime-cpudetection" option to 23 # you may want to add the "--enable-runtime-cpudetection" option to
21 # the line below, but beware: the resulting binary will run slower 24 # the line below, but beware: the resulting binary will run slower
25 $(CLEAN_ENV) \
22 ./configure --prefix=/usr --confdir=/etc/mplayer $(DEB_BUILD_OPTIONS) 26 ./configure --prefix=/usr --confdir=/etc/mplayer $(DEB_BUILD_OPTIONS)
23 27
24 touch configure-stamp 28 touch configure-stamp
25 29
26 build: configure-stamp build-stamp 30 build: configure-stamp build-stamp
27 build-stamp: 31 build-stamp:
28 dh_testdir 32 dh_testdir
29 33
30 # commands to compile the package. 34 # commands to compile the package.
35 $(CLEAN_ENV) \
31 ${MAKE} 36 ${MAKE}
32 37
33 touch build-stamp 38 touch build-stamp
34 39
35 clean: 40 clean: