comparison debian/rules @ 2759:ce39b5cc7e16

add gui, this way we can finally add usable entry to menus. ( Sveg Hartge <hartge@ds9.argh.org> )
author eyck
date Wed, 07 Nov 2001 10:06:51 +0000
parents 2fa80ba21968
children ab3cc8156c3d
comparison
equal deleted inserted replaced
2758:5e5cba50b1d0 2759:ce39b5cc7e16
10 configure: configure-stamp 10 configure: configure-stamp
11 configure-stamp: 11 configure-stamp:
12 dh_testdir 12 dh_testdir
13 # Add here commands to configure the package. 13 # Add here commands to configure the package.
14 $(checkdir) 14 $(checkdir)
15 ./configure --prefix=/usr 15 ./configure --prefix=/usr --enable-gui --enable-streaming
16 16
17 touch configure-stamp 17 touch configure-stamp
18 18
19 build: configure-stamp build-stamp 19 build: configure-stamp build-stamp
20 build-stamp: 20 build-stamp:
22 22
23 # Add here commands to compile the package. 23 # Add here commands to compile the package.
24 #$(MAKE) 24 #$(MAKE)
25 #/usr/bin/docbook-to-man debian/etherconf.sgml > etherconf.1 25 #/usr/bin/docbook-to-man debian/etherconf.sgml > etherconf.1
26 ${MAKE} mplayer 26 ${MAKE} mplayer
27 ${MAKE} mencoder
27 28
28 touch build-stamp 29 touch build-stamp
29 30
30 clean: 31 clean:
31 dh_testdir 32 dh_testdir
52 # Add here commands to install the package into debian/<packagename> 53 # Add here commands to install the package into debian/<packagename>
53 # $(MAKE) prefix=`pwd`/debian/`dh_listpackages`/usr install 54 # $(MAKE) prefix=`pwd`/debian/`dh_listpackages`/usr install
54 # $(MAKE) install prefix=$(CURDIR)/debian/tmp/usr 55 # $(MAKE) install prefix=$(CURDIR)/debian/tmp/usr
55 # install -d $(CURDIR)/debian/tmp/usr/bin 56 # install -d $(CURDIR)/debian/tmp/usr/bin
56 install -m 755 -s mplayer $(CURDIR)/debian/`dh_listpackages`/usr/bin/mplayer 57 install -m 755 -s mplayer $(CURDIR)/debian/`dh_listpackages`/usr/bin/mplayer
58 dh_link usr/bin/mplayer usr/bin/gmplayer
59
57 #Do we really need this?: 60 #Do we really need this?:
58 # install -o root -g root -m 4755 fibmap_mplayer usr/bin/fibmap_mplayer 61 # install -o root -g root -m 4755 fibmap_mplayer usr/bin/fibmap_mplayer
59 62
60 63
61 # Build architecture-independent files here. 64 # Build architecture-independent files here.