diff debian/rules @ 1397:225b8fb7653f

using debhelper instead of hardcoded stuff
author eyck
date Sat, 28 Jul 2001 07:53:11 +0000
parents d216f62ce921
children 3249bbc48bf9
line wrap: on
line diff
--- a/debian/rules	Sat Jul 28 05:54:02 2001 +0000
+++ b/debian/rules	Sat Jul 28 07:53:11 2001 +0000
@@ -1,55 +1,112 @@
 #!/usr/bin/make -f
 # Made with the aid of debmake, by Christoph Lameter,
 # based on the sample debian/rules file for GNU hello by Ian Jackson.
+#export DH_VERBOSE=1
+# This is the debhelper compatability version to use.
+export DH_COMPAT=1
 
 package=mplayer
 
-build:
+configure: configure-stamp
+configure-stamp:
+	dh_testdir
+	# Add here commands to configure the package.
 	$(checkdir)
 	./configure --prefix=/usr
+
+	touch configure-stamp
+
+build: configure-stamp build-stamp
+build-stamp:
+	dh_testdir
+
+	# Add here commands to compile the package.
+	#$(MAKE)
+	#/usr/bin/docbook-to-man debian/etherconf.sgml > etherconf.1
 	make dep
 	make mplayer
-	touch build
+
+
+	touch build-stamp
 
 clean:
-	$(checkdir)
-	-rm -f build
-	-$(MAKE) distclean
-	-rm -f `find . -name "*~"`
-	-rm -rf debian/tmp debian/files* core debian/substvars
+	dh_testdir
+	dh_testroot
+	rm -f build-stamp configure-stamp
 
-binary-indep: checkroot build
-	$(checkdir)
-# There are no architecture-independent files to be uploaded
-# generated by this package.  If there were any they would be
-# made here.
+	# Add here commands to clean up after the build process.
+	#-$(MAKE) clean
+#	$(checkdir)
+#	-rm -f build
+#	-$(MAKE) distclean
+#	-rm -f `find . -name "*~"`
+#	-rm -rf debian/tmp debian/files* core debian/substvars
+	dh_clean
 
 
 
-binary-arch: checkroot build
-	$(checkdir)
-	-rm -rf debian/tmp
-	install -d debian/tmp
-	cd debian/tmp && install -d `cat ../dirs`
+install: build
+	dh_testdir
+	dh_testroot
+	dh_clean -k
+	dh_installdirs
+
+	# Add here commands to install the package into debian/<packagename>
+#	$(MAKE) prefix=`pwd`/debian/`dh_listpackages`/usr install
 	$(MAKE) install prefix=`pwd`/debian/tmp/usr
 
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+
+# Build architecture-dependent files here.
+binary-arch: build install
+	dh_testdir
+	dh_testroot
+	dh_installdebconf	
+	dh_installdocs
+	dh_installexamples
+	dh_installmenu
+#	dh_installlogrotate
+#	dh_installemacsen
+#	dh_installpam
+#	dh_installmime
+#	dh_installinit
+#	dh_installcron
+	dh_installman
+	dh_installinfo
+#	dh_undocumented
+	dh_installchangelogs
+	dh_link
+	dh_strip
+	dh_compress
+	dh_fixperms
+#	dh_makeshlibs
+	dh_installdeb
+	dh_perl
+	dh_shlibdeps
+	dh_gencontrol
+	dh_md5sums
+	dh_builddeb
+
+
+
+#binary-arch: checkroot build
+#	$(checkdir)
+#	-rm -rf debian/tmp
+#	install -d debian/tmp
+#	cd debian/tmp && install -d `cat ../dirs`
+
 
 # Must have debmake installed for this to work. Otherwise please copy
 # /usr/bin/debstd into the debian directory and change debstd to debian/debstd
-	debstd 
-	dpkg-gencontrol -isp
-	chown -R root.root debian/tmp
-	chmod -R go=rX debian/tmp
-	dpkg --build debian/tmp ..
-
-define checkdir
-	test -f debian/rules
-endef
+#	debstd 
+#	dpkg-gencontrol -isp
+#	chown -R root.root debian/tmp
+#	chmod -R go=rX debian/tmp
+#	dpkg --build debian/tmp ..
 
 binary: binary-indep binary-arch
 
-checkroot:
-	$(checkdir)
-	test root = "`whoami`"
-
 .PHONY: binary binary-arch binary-indep clean checkroot