diff debian/daily-build.sh @ 31833:c9f9a077d760

Add new debian packaging based on official distro packages
author siretart
date Tue, 03 Aug 2010 13:02:07 +0000
parents
children 4551864b8e69
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/debian/daily-build.sh	Tue Aug 03 13:02:07 2010 +0000
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+# wrapper around dpkg-buildpackage to generate correct changelog
+# use "debian/daily-build.sh -b" to create binary packages
+# and "debian/daily-build.sh -S" to create a source package only
+
+LC_ALL=C svn info 2> /dev/null | grep Revision | cut -d' ' -f2
+version=$(LC_ALL=C svn info 2> /dev/null | grep Revision | cut -d' ' -f2)
+
+# ensure correct directory
+test -r debian/control || exit 1
+
+rm debian/changelog
+dch --create --empty --package mplayer -v 2:1.0~svn${version} "Daily build"
+
+dpkg-buildpackage -us -uc "$@"