view debian/rules @ 1347:448d1bf28f5a

Solaris 2.6 and older do not support MAP_ANON, just fail the mmap MAP_ANON attempt on such a system. The code tries mmap with /dev/zero and MIT-shm next. Fix a possible filedesc leak, when the code tries to mmap shared memeory via /dev/zero. Reuse the already open /dev/zero from a previous shmem_alloc call. (same change; now without changing the indentation of the code)
author jkeil
date Thu, 19 Jul 2001 20:32:13 +0000
parents d216f62ce921
children 225b8fb7653f
line wrap: on
line source

#!/usr/bin/make -f
# Made with the aid of debmake, by Christoph Lameter,
# based on the sample debian/rules file for GNU hello by Ian Jackson.

package=mplayer

build:
	$(checkdir)
	./configure --prefix=/usr
	make dep
	make mplayer
	touch build

clean:
	$(checkdir)
	-rm -f build
	-$(MAKE) distclean
	-rm -f `find . -name "*~"`
	-rm -rf debian/tmp debian/files* core debian/substvars

binary-indep: checkroot build
	$(checkdir)
# There are no architecture-independent files to be uploaded
# generated by this package.  If there were any they would be
# made here.



binary-arch: checkroot build
	$(checkdir)
	-rm -rf debian/tmp
	install -d debian/tmp
	cd debian/tmp && install -d `cat ../dirs`
	$(MAKE) install prefix=`pwd`/debian/tmp/usr


# Must have debmake installed for this to work. Otherwise please copy
# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
	debstd 
	dpkg-gencontrol -isp
	chown -R root.root debian/tmp
	chmod -R go=rX debian/tmp
	dpkg --build debian/tmp ..

define checkdir
	test -f debian/rules
endef

binary: binary-indep binary-arch

checkroot:
	$(checkdir)
	test root = "`whoami`"

.PHONY: binary binary-arch binary-indep clean checkroot