Mercurial > mplayer.hg
view debian/rules @ 3127:59ac428ae68d
Disable problematic ffmpeg.so support by default and remove die on 2.2.x
and older kernel, replacing it with more in depth info.
(Kernel SSE check will disable SSE, if needed!)
author | atmos4 |
---|---|
date | Mon, 26 Nov 2001 00:46:44 +0000 |
parents | ab3cc8156c3d |
children | 06911836febd |
line wrap: on
line source
#!/usr/bin/make -f # Made with the aid of debmake, by Christoph Lameter, # based on the sample debian/rules file for GNU hello by Ian Jackson. #export DH_VERBOSE=1 # This is the debhelper compatability version to use. export DH_COMPAT=2 package=mplayer configure: configure-stamp configure-stamp: dh_testdir # Add here commands to configure the package. $(checkdir) ./configure --prefix=/usr --enable-gui --enable-streaming touch configure-stamp build: configure-stamp build-stamp build-stamp: dh_testdir # Add here commands to compile the package. #$(MAKE) #/usr/bin/docbook-to-man debian/etherconf.sgml > etherconf.1 ${MAKE} mplayer touch build-stamp clean: dh_testdir dh_testroot rm -f build-stamp configure-stamp # Add here commands to clean up after the build process. #-$(MAKE) clean # $(checkdir) # -rm -f build -$(MAKE) distclean # -rm -f `find . -name "*~"` # -rm -rf debian/tmp debian/files* core debian/substvars dh_clean install: build dh_testdir dh_testroot dh_clean -k dh_installdirs # Add here commands to install the package into debian/<packagename> # $(MAKE) prefix=`pwd`/debian/`dh_listpackages`/usr install # $(MAKE) install prefix=$(CURDIR)/debian/tmp/usr # install -d $(CURDIR)/debian/tmp/usr/bin install -m 755 -s mplayer $(CURDIR)/debian/`dh_listpackages`/usr/bin/mplayer dh_link usr/bin/mplayer usr/bin/gmplayer #Do we really need this?: # install -o root -g root -m 4755 fibmap_mplayer usr/bin/fibmap_mplayer # Build architecture-independent files here. binary-indep: build install # We have nothing to do by default. # Build architecture-dependent files here. binary-arch: build install dh_testdir dh_testroot dh_installdebconf dh_installdocs DOCS/* dh_installexamples etc/example.conf dh_installmenu # dh_installmime dh_installmanpages TVout/fbset/fb.modes.5 TVout/fbset/fbset.8 dh_installinfo # dh_undocumented dh_installchangelogs dh_link dh_strip dh_compress dh_fixperms # dh_makeshlibs dh_installdeb dh_perl dh_shlibdeps dh_gencontrol dh_md5sums dh_builddeb #binary-arch: checkroot build # $(checkdir) # -rm -rf debian/tmp # install -d debian/tmp # cd debian/tmp && install -d `cat ../dirs` # Must have debmake installed for this to work. Otherwise please copy # /usr/bin/debstd into the debian directory and change debstd to debian/debstd # debstd # dpkg-gencontrol -isp # chown -R root.root debian/tmp # chmod -R go=rX debian/tmp # dpkg --build debian/tmp .. binary: binary-indep binary-arch .PHONY: binary binary-arch binary-indep clean checkroot