diff configure.in @ 0:2413369d1b01

initial import
author Yoshiki Yazawa <yaz@cc.rim.or.jp>
date Tue, 29 Apr 2008 14:35:36 +0900
parents
children 799955af57ad
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/configure.in	Tue Apr 29 14:35:36 2008 +0900
@@ -0,0 +1,52 @@
+#                                               -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(pidgin-twitter, 0.1.0, yaz@honeyplanet.jp)
+AC_CONFIG_SRCDIR([pidgin-twitter.c])
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+
+# Checks for libraries.
+PKG_CHECK_MODULES(AUDACIOUS, [libpcre >= 6.0.0], , [
+        AC_MSG_RESULT(no)
+        AC_MSG_ERROR([
+
+You must have libpcre >= 6.0.0 headers installed to build.
+])])
+PCRE_CFLAGS=`pkg-config --cflags libpcre 2> /dev/null`
+PCRE_LIBS=`pkg-config --libs libpcre 2> /dev/null`
+PCRE_LIB_DIR=`pkg-config --variable=lib_dir libpcre 2> /dev/null`
+AC_SUBST(PCRE_CFLAGS)
+AC_SUBST(PCRE_LIBS)
+AC_SUBST(PCRE_LIB_DIR)
+
+PKG_CHECK_MODULES(PIDGIN, [pidgin >= 2.0.0], , [
+        AC_MSG_RESULT(no)
+        AC_MSG_ERROR([
+
+You must have pidgin >= 2.0.0 development headers installed to build.
+])])
+PIDGIN_CFLAGS=`pkg-config --cflags pidgin 2> /dev/null`
+PIDGIN_LIBS=`pkg-config --libs pidgin 2> /dev/null`
+PIDGIN_LIB_DIR=`pkg-config --variable=libdir pidgin 2> /dev/null`
+AC_SUBST(PIDGIN_CFLAGS)
+AC_SUBST(PIDGIN_LIBS)
+AC_SUBST(PIDGIN_LIB_DIR)
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([stdlib.h string.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+
+# Checks for library functions.
+AC_CHECK_FUNCS([strstr])
+
+#AC_CONFIG_FILES([Makefile])
+AC_OUTPUT(Makefile)
+
+dnl  LocalWords:  PCRE