diff console/Makefile.am @ 14191:009db0b357b5

This is a hand-crafted commit to migrate across subversion revisions 16854:16861, due to some vagaries of the way the original renames were done. Witness that monotone can do in one revision what svn had to spread across several.
author Ethan Blanton <elb@pidgin.im>
date Sat, 16 Dec 2006 04:59:55 +0000
parents
children 60b1bc8dbf37
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/console/Makefile.am	Sat Dec 16 04:59:55 2006 +0000
@@ -0,0 +1,65 @@
+#libgnt currently needs to have autogen run for there to be a Makefile...
+# SUBDIRS = libgnt
+
+bin_PROGRAMS = gntgaim
+
+gntgaim_SOURCES = \
+	gntaccount.c \
+	gntblist.c \
+	gntconn.c \
+	gntconv.c \
+	gntdebug.c \
+	gntgaim.c \
+	gntnotify.c \
+	gntplugin.c \
+	gntprefs.c \
+	gntrequest.c \
+	gntstatus.c \
+	gntui.c
+
+gntgaim_headers = \
+	gntaccount.h \
+	gntblist.h \
+	gntconn.h \
+	gntconv.h \
+	gntdebug.h \
+	gntnotify.h \
+	gntplugin.c \
+	gntprefs.h \
+	gntrequest.h \
+	gntstatus.h \
+	gntui.h
+
+gntgaimincludedir=$(includedir)/gaim/gnt
+gntgaiminclude_HEADERS = \
+	$(gntgaim_headers)
+
+gntgaim_DEPENDENCIES = @LIBOBJS@ $(STATIC_LINK_LIBS) $(MS_LIBS)
+gntgaim_LDFLAGS = -export-dynamic
+gntgaim_LDADD = \
+	@LIBOBJS@ \
+	$(DBUS_LIBS) \
+	$(GSTREAMER_LIBS) \
+	$(STATIC_LINK_LIBS) \
+	$(XSS_LIBS) \
+	$(SM_LIBS) \
+	$(INTLLIBS) \
+	$(GLIB_LIBS) \
+	$(LIBXML_LIBS) \
+	-L./libgnt/ -lgnt \
+	-L$(top_srcdir)/core -lgaim
+
+AM_CPPFLAGS = \
+	-DSTANDALONE \
+	-DBR_PTHREADS=0 \
+	-DDATADIR=\"$(datadir)\" \
+	-DLIBDIR=\"$(libdir)/gaim/\" \
+	-DLOCALEDIR=\"$(datadir)/locale\" \
+	-DSYSCONFDIR=\"$(sysconfdir)\" \
+	-I$(top_srcdir)/core/ \
+	-I ./libgnt/ \
+	$(GSTREAMER_CFLAGS) \
+	$(DEBUG_CFLAGS) \
+	$(GLIB_CFLAGS) \
+	$(DBUS_CFLAGS) \
+	$(LIBXML_CFLAGS)