diff src/Makefile.am @ 5859:022786c7ab53

[gaim-migrate @ 6290] CUI is gone, long live gaim-remote! The old CUI functionality, which was for remote-controlling gaim, is now a Core Plugin, so any future UI (including the current, normal gaim gtk UI) can be remote-controlled. Applications will soon be able to link against the library and header files and provide their own remote-control of gaim, but why bother? :) If you use gaim-remote, make sure to load the new plugin. It won't auto-load. committer: Tailor Script <tailor@pidgin.im>
author Christian Hammond <chipx86@chipx86.com>
date Sat, 14 Jun 2003 06:06:40 +0000
parents 1d140b31d4b3
children 964e4f94fc56
line wrap: on
line diff
--- a/src/Makefile.am	Fri Jun 13 23:49:26 2003 +0000
+++ b/src/Makefile.am	Sat Jun 14 06:06:40 2003 +0000
@@ -16,7 +16,6 @@
 	connection.h \
 	conversation.c \
 	conversation.h \
-	core.c \
 	core.h \
 	debug.c \
 	debug.h \
@@ -55,7 +54,6 @@
 	dnd-hints.c \
 	dnd-hints.h \
 	gaim.h \
-	gaim-socket.h \
 	gaim-disclosure.c \
 	gaim-disclosure.h \
 	gaimrc.c \
@@ -97,7 +95,6 @@
 	md5.h \
 	privacy.h \
 	session.c \
-	socket.c \
 	stock.c \
 	stock.h \
 	themes.c \
@@ -115,7 +112,10 @@
 	$(INTLLIBS) \
 	$(GTKSPELL_LIBS)
 
-gaim_remote_SOURCES = gaim-remote.c socket.c
+gaim_remote_SOURCES = \
+	gaim-remote.c \
+	$(top_srcdir)/plugins/gaim-remote/remote-socket.c
+
 gaim_remote_DEPENDENCIES = @LIBOBJS@
 gaim_remote_LDADD = @LIBOBJS@ $(GLIB_LIBS) $(INTLLIBS)
 
@@ -126,4 +126,5 @@
 	-DLOCALEDIR=\"$(datadir)/locale\" \
 	-DLIBDIR=\"$(libdir)/gaim/\" \
 	-DDATADIR=\"$(datadir)\" \
-	$(DEBUG_CFLAGS)
+	$(DEBUG_CFLAGS) \
+	-I$(top_srcdir)/plugins