diff configure.in @ 423:0d4e80bdb96b

[gaim-migrate @ 433] No more --enable-oscar option. From now on, it's a toggle in the preferences. PLEASE DO NOT USE OSCAR, even though it's very easy to. committer: Tailor Script <tailor@pidgin.im>
author Eric Warmenhoven <eric@warmenhoven.org>
date Wed, 21 Jun 2000 19:33:58 +0000
parents e2610cc1fcb3
children e1c09b8c8bb1
line wrap: on
line diff
--- a/configure.in	Mon Jun 19 21:58:32 2000 +0000
+++ b/configure.in	Wed Jun 21 19:33:58 2000 +0000
@@ -36,13 +36,10 @@
 AC_ARG_ENABLE(gnome, [  --enable-gnome          compile as a GNOME applet],enable_gnome=yes,)
 AM_CONDITIONAL(GNOMEAPPLET, test x$enable_gnome = xyes)
 AC_ARG_ENABLE(esd,   [  --disable-esd           Turn off ESD (default=auto)],enable_esd=no,enable_esd=yes)
-AC_ARG_ENABLE(oscar, [  --enable-oscar          Enable Oscar support (experimental)],enable_oscar=yes,)
 AC_ARG_ENABLE(nas,   [  --enable-nas            Enable NAS (Network Audio System) support],enable_nas=yes,)
 AC_ARG_ENABLE(plugins, [  --disable-plugins       compile with out plugin support],enable_plugins=no,enable_plugins=yes)
 AM_CONDITIONAL(PLUGINS, test x$enable_plugins = xyes)
 
-LIBFAIM_DO=""
-
 if test "$enable_debug" = yes ; then
 dnl	someone please tell me what -d does
 dnl	CFLAGS="$CFLAGS -Wall -d -g"
@@ -50,16 +47,11 @@
 	AC_DEFINE(DEBUG)
 fi
 
-if test "$enable_oscar" = yes ; then
-	CFLAGS="$CFLAGS -I../libfaim/faim"
-	AC_DEFINE(USE_OSCAR)
-        LDADD="$LDADD -L../libfaim -lfaim -pthread"
-        LIBFAIM_DO="libfaim.a"
-fi
-
 AM_PATH_GLIB(1.2.0)
 AM_PATH_GTK(1.2.0,,,gthread)
 LIBS="$LIBS $GTK_LIBS"
+CFLAGS="$CFLAGS -I../libfaim/faim"
+LDADD="$LDADD -L../libfaim -lfaim -pthread"
 
 if test "$enable_gnome" = yes ; then
 	GNOME_INIT(applets)