diff finch/Makefile.am @ 15818:0e3a8505ebbe

renamed gaim-text to finch
author Sean Egan <seanegan@gmail.com>
date Sun, 18 Mar 2007 19:38:15 +0000
parents
children 32c366eeeb99
line wrap: on
line diff
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/finch/Makefile.am	Sun Mar 18 19:38:15 2007 +0000
@@ -0,0 +1,77 @@
+if ENABLE_GNT
+
+EXTRA_DIST = \
+		getopt.c \
+		getopt.h \
+		getopt1.c
+
+SUBDIRS = libgnt plugins
+
+bin_PROGRAMS = finch
+
+finch_SOURCES = \
+	gntaccount.c \
+	gntblist.c \
+	gntconn.c \
+	gntconv.c \
+	gntdebug.c \
+	gntft.c \
+	gntgaim.c \
+	gntidle.c \
+	gntnotify.c \
+	gntplugin.c \
+	gntpounce.c \
+	gntprefs.c \
+	gntrequest.c \
+	gntstatus.c \
+	gntui.c
+
+finch_headers = \
+	gntaccount.h \
+	gntblist.h \
+	gntconn.h \
+	gntconv.h \
+	gntdebug.h \
+	gntft.h \
+	gntgaim.h \
+	gntidle.h \
+	gntnotify.h \
+	gntplugin.h \
+	gntpounce.h \
+	gntprefs.h \
+	gntrequest.h \
+	gntstatus.h \
+	gntui.h
+
+finchincludedir=$(includedir)/gaim/gnt
+finchinclude_HEADERS = \
+	$(finch_headers)
+
+finch_DEPENDENCIES = @LIBOBJS@
+finch_LDFLAGS = -export-dynamic
+finch_LDADD = \
+	@LIBOBJS@ \
+	$(DBUS_LIBS) \
+	$(INTLLIBS) \
+	$(GLIB_LIBS) \
+	$(LIBXML_LIBS) \
+	$(GNT_LIBS) \
+	./libgnt/libgnt.la \
+	$(top_builddir)/libpurple/libpurple.la
+
+AM_CPPFLAGS = \
+	-DSTANDALONE \
+	-DBR_PTHREADS=0 \
+	-DDATADIR=\"$(datadir)\" \
+	-DLIBDIR=\"$(libdir)/gaim/\" \
+	-DLOCALEDIR=\"$(datadir)/locale\" \
+	-DSYSCONFDIR=\"$(sysconfdir)\" \
+	-I$(top_srcdir)/libpurple/ \
+	-I$(top_srcdir) \
+	-I$(srcdir)/libgnt/ \
+	$(DEBUG_CFLAGS) \
+	$(GLIB_CFLAGS) \
+	$(DBUS_CFLAGS) \
+	$(LIBXML_CFLAGS) \
+	$(GNT_CFLAGS)
+endif