diff Makefile.am @ 23892:111b464f6845

Add release-time candy 'make release' and 'make packages' to the Makefile. make release will run a distcheck followed by building packages. make packages will build a .tar.gz, .tar.bz2, and src.rpm, and sign all three with your default gpg key. The failure of gpg will abort the process.
author Ethan Blanton <elb@pidgin.im>
date Mon, 25 Aug 2008 02:46:51 +0000
parents 0085d8b80bc4
children d64673562530
line wrap: on
line diff
--- a/Makefile.am	Sun Aug 24 16:59:06 2008 +0000
+++ b/Makefile.am	Mon Aug 25 02:46:51 2008 +0000
@@ -30,6 +30,15 @@
 distcheck-hook: libpurple/plugins/perl/common/Purple.pm pidgin/plugins/perl/common/Pidgin.pm
 #	cp libpurple/plugins/perl/common/Gaim.pm $(distdir)/libpurple/plugins/perl/common
 
+release: distcheck packages
+
+packages: dist-gzip dist-bzip2
+	gpg -ab pidgin-$(PACKAGE_VERSION).tar.gz
+	gpg -ab pidgin-$(PACKAGE_VERSION).tar.bz2
+	gpg --verify pidgin-$(PACKAGE_VERSION).tar.gz.asc pidgin-$(PACKAGE_VERSION).tar.gz
+	gpg --verify pidgin-$(PACKAGE_VERSION).tar.bz2.asc pidgin-$(PACKAGE_VERSION).tar.bz2
+	rpmbuild -ts --sign --with avahi --with dbus --with meanwhile --with sasl --with silc --with tcl pidgin-$(PACKAGE_VERSION).tar.bz2
+
 if ENABLE_GTK
 appsdir = $(datadir)/applications
 apps_in_files = pidgin.desktop.in