diff configure.ac @ 23984:156913375b3f

Report dbus/nm availability correctly
author Sadrul Habib Chowdhury <imadil@gmail.com>
date Thu, 04 Sep 2008 21:57:40 +0000
parents 3273b22b6a7b
children 2f83c37c65e3 bb99ee66120e 5c76f76ee9db
line wrap: on
line diff
--- a/configure.ac	Thu Sep 04 03:43:32 2008 +0000
+++ b/configure.ac	Thu Sep 04 21:57:40 2008 +0000
@@ -1240,6 +1240,7 @@
 		AC_SUBST(DBUS_LIBS)
 		enable_dbus=yes
 	], [
+	enable_dbus=no
 	if test "x$force_deps" = "xyes" ; then
 		AC_MSG_ERROR([
 D-Bus development headers not found.
@@ -1256,6 +1257,7 @@
 			AC_SUBST(NETWORKMANAGER_LIBS)
 			AC_DEFINE(HAVE_NETWORKMANAGER, 1, [Define if we have NetworkManager.])
 		], [
+			enable_nm=no
 			if test "x$force_deps" = "xyes" ; then
 				AC_MSG_ERROR([
 NetworkManager development headers not found.
@@ -1263,6 +1265,8 @@
 ])
 			fi])
 	fi
+else
+	enable_nm=no
 fi
 
 dnl #######################################################################