diff libpurple/Makefile.am @ 15974:1a12ce76c4f4

The network module now registers the signal 'network-configuration-changed' and emits it when a network change is detected via libnm or the win32 network monitor. The UI could also emit this signal if it knows something network.c doesn't. UPnP and NAT-PMP respond to the signal by clearing their IP address caches; changing networks without quitting/relaunching will now lead to the new IP address being (lazily) determined. This commit also enables nat-pmp and adds nat-pmp.[h|c] to the build process; please let me know if there are any problems building, as I only have OS X test machines.
author Evan Schoenberg <evan.s@dreskin.net>
date Sat, 31 Mar 2007 20:33:54 +0000
parents c6e563dfaa7a
children 634b96915d2e
line wrap: on
line diff
--- a/libpurple/Makefile.am	Sat Mar 31 04:36:05 2007 +0000
+++ b/libpurple/Makefile.am	Sat Mar 31 20:33:54 2007 +0000
@@ -49,6 +49,7 @@
 	imgstore.c \
 	log.c \
 	mime.c \
+	nat-pmp.c \
 	network.c \
 	ntlm.c \
 	notify.c \
@@ -99,6 +100,7 @@
 	imgstore.h \
 	log.h \
 	mime.h \
+	nat-pmp.h \
 	network.h \
 	notify.h \
 	ntlm.h \