diff plugins/Makefile.am @ 11435:1a2eaba2bc13

[gaim-migrate @ 13672] Some autotools tweak from Kevin Stange to let autogen.sh pass with automake 1.9 committer: Tailor Script <tailor@pidgin.im>
author Gary Kramlich <grim@reaperworld.com>
date Sun, 04 Sep 2005 02:03:48 +0000
parents a6d446cf090f
children 9b3833da6840
line wrap: on
line diff
--- a/plugins/Makefile.am	Sat Sep 03 15:01:56 2005 +0000
+++ b/plugins/Makefile.am	Sun Sep 04 02:03:48 2005 +0000
@@ -12,9 +12,17 @@
 TCL_DIR = tcl
 endif
 
+if ENABLE_DBUS
+DBUS_LTLIB = dbus-example.la
+
+# Only use music messaging if dbus is enabled
+MUSICMESSAGING_DIR = musicmessaging
+endif
+
 SUBDIRS = \
 	docklet $(GEVOLUTION_DIR) gestures \
-	$(PERL_DIR) ssl $(TCL_DIR) ticker
+	$(PERL_DIR) ssl $(TCL_DIR) ticker \
+	$(MUSICMESSAGING_DIR)
 
 plugindir = $(libdir)/gaim
 
@@ -43,7 +51,8 @@
 	relnot.la        \
 	spellchk.la      \
 	statenotify.la   \
-	timestamp.la
+	timestamp.la     \
+	$(DBUS_LTLIB)
 
 autorecon_la_SOURCES    = autorecon.c
 
@@ -60,13 +69,9 @@
 
 if ENABLE_DBUS
 
-# Only use music messaging if dbus is enabled
-SUBDIRS += musicmessaging
-
 CLEANFILES              = dbus-example-bindings.c
 dbus_example_la_LDFLAGS = -module -avoid-version $(GLIB_LIBS) $(DBUS_LIBS)
 dbus_example_la_SOURCES = dbus-example.c
-plugin_LTLIBRARIES     += dbus-example.la
 
 .PHONY: always