diff configure.ac @ 13806:25e63008d3bb

[gaim-migrate @ 16229] Use libxml2 for XML parsing, if available. The biggest benefit from this is actual support for XML namespaces. This fixes a handful of Google Talk integration problems, including typing notifications and buddy icons. committer: Tailor Script <tailor@pidgin.im>
author Sean Egan <seanegan@gmail.com>
date Thu, 08 Jun 2006 01:03:51 +0000
parents 78de76055f59
children cd93e6e90044
line wrap: on
line diff
--- a/configure.ac	Wed Jun 07 15:58:27 2006 +0000
+++ b/configure.ac	Thu Jun 08 01:03:51 2006 +0000
@@ -171,6 +171,17 @@
   AC_DEFINE(USE_GSTREAMER, 1, [Use GStreamer for making sounds])
 fi
 
+dnl #################
+dnl # LibXML2
+dnl #################
+enable_libxml=yes
+PKG_CHECK_MODULES(LIBXML, libxml-2.0, ,enable_libxml=no)
+AC_SUBST(LIBXML_CFLAGS)
+AC_SUBST(LIBXML_LIBS)
+if test "x$enable_libxml" = "xyes"; then
+	AC_DEFINE(HAVE_LIBXML, 1, [Use libxml2 for xml parsing])
+fi
+
 dnl #######################################################################
 dnl # Check for Meanwhile headers (for Sametime)
 dnl #######################################################################