diff configure.ac @ 14217:28b1cebaa328

[gaim-migrate @ 16898] libgaim and gaim should not link against ncursesw. libgaim should not link against gstreamer. committer: Tailor Script <tailor@pidgin.im>
author Sadrul Habib Chowdhury <imadil@gmail.com>
date Sun, 20 Aug 2006 07:13:35 +0000
parents 830a68fc9a54
children c18bdf510325
line wrap: on
line diff
--- a/configure.ac	Sun Aug 20 07:11:09 2006 +0000
+++ b/configure.ac	Sun Aug 20 07:13:35 2006 +0000
@@ -808,12 +808,14 @@
 dnl #######################################################################
 dnl # GNT Gaim
 dnl #######################################################################
+GNT_LIBS=
 if test "x$enable_gnt" = "xyes"; then
-	AC_CHECK_LIB(ncursesw, initscr, , [enable_gnt=no])
-	AC_CHECK_LIB(panelw, update_panels, , [enable_gnt=no])
+	AC_CHECK_LIB(ncursesw, initscr, [GNT_LIBS="-lncursesw"], [enable_gnt=no])
+	AC_CHECK_LIB(panelw, update_panels, [GNT_LIBS="$GNT_LIBS -lpanelw"], [enable_gnt=no])
 else
 	enable_gnt=no
 fi
+AC_SUBST(GNT_LIBS)
 AM_CONDITIONAL(ENABLE_GNT, test "x$enable_gnt" = "xyes")
 
 dnl #######################################################################