diff libpurple/protocols/jabber/Makefile.am @ 24332:2b62300d2c19

Use libtool to build static archives when --with-static-prpls is passed to configure. Does anyone know why we weren't using libtool before? We were building old-fashioned .a files. But libtool archives (.la) can contain either static or shared libraries. I found it a lot easier to get static prpl compilation working after making this change (that is to say, it worked). Without this I got this error, which is probably fixable, but consistently using libtool seems like it makes things easier: *** Warning: Linking the shared library libpurple.la against the *** static library ../libpurple/protocols/msn/libmsn.a is not portable! /usr/bin/ld: ../libpurple/protocols/msn/libmsn.a(libmsn_a-msn.o): relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC ../libpurple/protocols/msn/libmsn.a: could not read symbols: Bad value collect2: ld returned 1 exit status
author Mark Doliner <mark@kingant.net>
date Wed, 12 Nov 2008 11:30:51 +0000
parents 4ac5db6e39f3
children 7183d12b96ed 9ab681f23007 5dd25c58b65e adf153852bcf
line wrap: on
line diff
--- a/libpurple/protocols/jabber/Makefile.am	Wed Nov 12 09:40:05 2008 +0000
+++ b/libpurple/protocols/jabber/Makefile.am	Wed Nov 12 11:30:51 2008 +0000
@@ -1,7 +1,7 @@
 EXTRA_DIST = \
-		Makefile.mingw \
-		win32/posix.uname.c \
-		win32/utsname.h
+	Makefile.mingw \
+	win32/posix.uname.c \
+	win32/utsname.h
 
 pkgdir = $(libdir)/purple-$(PURPLE_MAJOR_VERSION)
 
@@ -59,20 +59,16 @@
 if STATIC_JABBER
 
 st = -DPURPLE_STATIC_PRPL
-noinst_LIBRARIES = libjabber.a
-pkg_LTLIBRARIES =
-
-libjabber_a_SOURCES = $(JABBERSOURCES) libxmpp.c
-libjabber_a_CFLAGS  = $(AM_CFLAGS)
+noinst_LTLIBRARIES   = libjabber.la
+libjabber_la_SOURCES = $(JABBERSOURCES) libxmpp.c
+libjabber_la_CFLAGS  = $(AM_CFLAGS)
 
 else
 
 st =
-pkg_LTLIBRARIES = libjabber.la libxmpp.la
-noinst_LIBRARIES =
-
+pkg_LTLIBRARIES      = libjabber.la libxmpp.la
 libjabber_la_SOURCES = $(JABBERSOURCES)
-libjabber_la_LIBADD = $(GLIB_LIBS) $(SASL_LIBS) $(LIBXML_LIBS)
+libjabber_la_LIBADD  = $(GLIB_LIBS) $(SASL_LIBS) $(LIBXML_LIBS)
 
 libxmpp_la_SOURCES = libxmpp.c
 libxmpp_la_LIBADD = libjabber.la