diff libpurple/protocols/null/Makefile.am @ 24332:2b62300d2c19

Use libtool to build static archives when --with-static-prpls is passed to configure. Does anyone know why we weren't using libtool before? We were building old-fashioned .a files. But libtool archives (.la) can contain either static or shared libraries. I found it a lot easier to get static prpl compilation working after making this change (that is to say, it worked). Without this I got this error, which is probably fixable, but consistently using libtool seems like it makes things easier: *** Warning: Linking the shared library libpurple.la against the *** static library ../libpurple/protocols/msn/libmsn.a is not portable! /usr/bin/ld: ../libpurple/protocols/msn/libmsn.a(libmsn_a-msn.o): relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC ../libpurple/protocols/msn/libmsn.a: could not read symbols: Bad value collect2: ld returned 1 exit status
author Mark Doliner <mark@kingant.net>
date Wed, 12 Nov 2008 11:30:51 +0000
parents afee8b840d91
children
line wrap: on
line diff
--- a/libpurple/protocols/null/Makefile.am	Wed Nov 12 09:40:05 2008 +0000
+++ b/libpurple/protocols/null/Makefile.am	Wed Nov 12 11:30:51 2008 +0000
@@ -1,4 +1,6 @@
-EXTRA_DIST = README Makefile.mingw
+EXTRA_DIST = \
+	Makefile.mingw \
+	README
 
 pkgdir = $(libdir)/purple-$(PURPLE_MAJOR_VERSION)
 
@@ -10,7 +12,7 @@
 
 # nullprpl isn't built by default. when it is built, it's dynamically linked.
 st =
-pkg_LTLIBRARIES   = libnull.la
+pkg_LTLIBRARIES    = libnull.la
 libnull_la_SOURCES = $(NULLSOURCES)
 libnull_la_LIBADD  = $(GLIB_LIBS)