diff libpurple/protocols/simple/Makefile.am @ 24332:2b62300d2c19

Use libtool to build static archives when --with-static-prpls is passed to configure. Does anyone know why we weren't using libtool before? We were building old-fashioned .a files. But libtool archives (.la) can contain either static or shared libraries. I found it a lot easier to get static prpl compilation working after making this change (that is to say, it worked). Without this I got this error, which is probably fixable, but consistently using libtool seems like it makes things easier: *** Warning: Linking the shared library libpurple.la against the *** static library ../libpurple/protocols/msn/libmsn.a is not portable! /usr/bin/ld: ../libpurple/protocols/msn/libmsn.a(libmsn_a-msn.o): relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC ../libpurple/protocols/msn/libmsn.a: could not read symbols: Bad value collect2: ld returned 1 exit status
author Mark Doliner <mark@kingant.net>
date Wed, 12 Nov 2008 11:30:51 +0000
parents 441945083737
children adf153852bcf
line wrap: on
line diff
--- a/libpurple/protocols/simple/Makefile.am	Wed Nov 12 09:40:05 2008 +0000
+++ b/libpurple/protocols/simple/Makefile.am	Wed Nov 12 11:30:51 2008 +0000
@@ -1,5 +1,5 @@
 EXTRA_DIST = \
-		Makefile.mingw
+	Makefile.mingw
 
 pkgdir = $(libdir)/purple-$(PURPLE_MAJOR_VERSION)
 
@@ -9,21 +9,21 @@
 	sipmsg.c \
 	sipmsg.h
 
-AM_CFLAGS = $(st) 
+AM_CFLAGS = $(st)
 
 libsimple_la_LDFLAGS = -module -avoid-version
 
 if STATIC_MSN
 
 st = -DPURPLE_STATIC_PRPL
-noinst_LIBRARIES = libsimple.a
-libsimple_a_SOURCES = $(SIMPLESOURCES)
-libsimple_a_CFLAGS  = $(AM_CFLAGS)
+noinst_LTLIBRARIES   = libsimple.la
+libsimple_la_SOURCES = $(SIMPLESOURCES)
+libsimple_la_CFLAGS  = $(AM_CFLAGS)
 
 else
 
 st =
-pkg_LTLIBRARIES   = libsimple.la
+pkg_LTLIBRARIES      = libsimple.la
 libsimple_la_SOURCES = $(SIMPLESOURCES)
 libsimple_la_LIBADD  = $(GLIB_LIBS)