diff libpurple/protocols/toc/Makefile.am @ 24332:2b62300d2c19

Use libtool to build static archives when --with-static-prpls is passed to configure. Does anyone know why we weren't using libtool before? We were building old-fashioned .a files. But libtool archives (.la) can contain either static or shared libraries. I found it a lot easier to get static prpl compilation working after making this change (that is to say, it worked). Without this I got this error, which is probably fixable, but consistently using libtool seems like it makes things easier: *** Warning: Linking the shared library libpurple.la against the *** static library ../libpurple/protocols/msn/libmsn.a is not portable! /usr/bin/ld: ../libpurple/protocols/msn/libmsn.a(libmsn_a-msn.o): relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC ../libpurple/protocols/msn/libmsn.a: could not read symbols: Bad value collect2: ld returned 1 exit status
author Mark Doliner <mark@kingant.net>
date Wed, 12 Nov 2008 11:30:51 +0000
parents 441945083737
children
line wrap: on
line diff
--- a/libpurple/protocols/toc/Makefile.am	Wed Nov 12 09:40:05 2008 +0000
+++ b/libpurple/protocols/toc/Makefile.am	Wed Nov 12 11:30:51 2008 +0000
@@ -1,6 +1,6 @@
 EXTRA_DIST = \
-		PROTOCOL \
-		Makefile.mingw
+	PROTOCOL \
+	Makefile.mingw
 
 pkgdir = $(libdir)/purple-$(PURPLE_MAJOR_VERSION)
 
@@ -13,9 +13,9 @@
 if STATIC_TOC
 
 st = -DPURPLE_STATIC_PRPL
-noinst_LIBRARIES = libtoc.a
-libtoc_a_SOURCES = $(TOCSOURCES)
-libtoc_a_CFLAGS  = $(AM_CFLAGS)
+noinst_LTLIBRARIES = libtoc.la
+libtoc_la_SOURCES  = $(TOCSOURCES)
+libtoc_la_CFLAGS   = $(AM_CFLAGS)
 
 else