diff libpurple/protocols/zephyr/Makefile.am @ 24332:2b62300d2c19

Use libtool to build static archives when --with-static-prpls is passed to configure. Does anyone know why we weren't using libtool before? We were building old-fashioned .a files. But libtool archives (.la) can contain either static or shared libraries. I found it a lot easier to get static prpl compilation working after making this change (that is to say, it worked). Without this I got this error, which is probably fixable, but consistently using libtool seems like it makes things easier: *** Warning: Linking the shared library libpurple.la against the *** static library ../libpurple/protocols/msn/libmsn.a is not portable! /usr/bin/ld: ../libpurple/protocols/msn/libmsn.a(libmsn_a-msn.o): relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC ../libpurple/protocols/msn/libmsn.a: could not read symbols: Bad value collect2: ld returned 1 exit status
author Mark Doliner <mark@kingant.net>
date Wed, 12 Nov 2008 11:30:51 +0000
parents 313b87adb730
children adf153852bcf
line wrap: on
line diff
--- a/libpurple/protocols/zephyr/Makefile.am	Wed Nov 12 09:40:05 2008 +0000
+++ b/libpurple/protocols/zephyr/Makefile.am	Wed Nov 12 11:30:51 2008 +0000
@@ -62,7 +62,6 @@
 	zephyr_err.c \
 	zephyr_err.h \
 	zephyr_internal.h \
-	\
 	zephyr.c
 
 ZEPHYRSOURCESEXT = zephyr.c
@@ -78,10 +77,10 @@
 if STATIC_ZEPHYR
 
 st = -DPURPLE_STATIC_PRPL -Dlint
-noinst_LIBRARIES = libzephyr.a
-libzephyr_a_SOURCES = $(ZEPHYRSOURCES)
-libzephyr_a_CFLAGS  = $(AM_CFLAGS)
-libzephyr_a_LIBADD  = $(ZEPHYRLIBS)
+noinst_LTLIBRARIES   = libzephyr.la
+libzephyr_la_SOURCES = $(ZEPHYRSOURCES)
+libzephyr_la_CFLAGS  = $(AM_CFLAGS)
+libzephyr_la_LIBADD  = $(ZEPHYRLIBS)
 
 else
 
@@ -90,7 +89,7 @@
 
 if EXTERNAL_LIBZEPHYR
 libzephyr_la_SOURCES = $(ZEPHYRSOURCESEXT)
-libzephyr_la_LIBADD = $(GLIB_LIBS) $(ZEPHYRLIBSEXT)
+libzephyr_la_LIBADD  = $(GLIB_LIBS) $(ZEPHYRLIBSEXT)
 else
 libzephyr_la_SOURCES = $(ZEPHYRSOURCES)
 libzephyr_la_LIBADD  = $(GLIB_LIBS) $(ZEPHYRLIBS)