diff libpurple/tests/Makefile.am @ 28560:2da9e4266742

Add a test for qq's qq_encrypt function. Refs #10191. The string of length 7 demonstrates the bug: 7+16=23, but the qq_encrypt function at least thinks that it is writing 24 bytes
author Mark Doliner <mark@kingant.net>
date Fri, 04 Sep 2009 06:23:41 +0000
parents 42359a734696
children 338eeaf371e2
line wrap: on
line diff
--- a/libpurple/tests/Makefile.am	Fri Sep 04 05:26:22 2009 +0000
+++ b/libpurple/tests/Makefile.am	Fri Sep 04 06:23:41 2009 +0000
@@ -11,6 +11,7 @@
 	    tests.h \
 		test_cipher.c \
 		test_jabber_jutil.c \
+		test_qq.c \
 		test_yahoo_util.c \
 		test_util.c \
 		$(top_builddir)/libpurple/util.h
@@ -28,6 +29,7 @@
         @CHECK_LIBS@ \
 		$(GLIB_LIBS) \
 		$(top_builddir)/libpurple/protocols/jabber/libjabber.la \
+		$(top_builddir)/libpurple/protocols/qq/libqq.la \
 		$(top_builddir)/libpurple/protocols/yahoo/libymsg.la \
 		$(top_builddir)/libpurple/libpurple.la