diff configure.ac @ 11067:2eca9ed49469

[gaim-migrate @ 13048] Modified configure.ac so that it rejects dbus builds with the dbus library older than 0.34 Added a simple object registration system to the dbus implementation so that it is possible to query object properties remotely (eg. give me property "name" of buddy with id = 5). committer: Tailor Script <tailor@pidgin.im>
author Piotr Zielinski <zielaj>
date Thu, 07 Jul 2005 15:43:48 +0000
parents df0241eb602c
children fdb8ba7a4857
line wrap: on
line diff
--- a/configure.ac	Thu Jul 07 15:43:05 2005 +0000
+++ b/configure.ac	Thu Jul 07 15:43:48 2005 +0000
@@ -318,14 +318,19 @@
 if test "x$enable_dbus" = "xyes"; then
    	PKG_CHECK_MODULES(DBUS, [dbus-1 >= 0.34 dbus-glib-1 >= 0.34],
 	[
-		AC_DEFINE(HAVE_DBUS, 1, [Define if we're using DBUS.])
 		AC_SUBST(DBUS_CFLAGS)
 		AC_SUBST(DBUS_LIBS)   	
-		echo "Building with DBUS support"
+	],
+	[
+		enable_dbus=no
 	])
+fi
+
+if test "x$enable_dbus" = "xyes"; then
+   	AC_DEFINE(HAVE_DBUS, 1, [Define if we're using DBUS.])
+	echo "Building with DBUS support"
 else
 	echo "Building without DBUS support"
-	enable_dbus=no
 fi
 
 AM_CONDITIONAL(ENABLE_DBUS, test "x$enable_dbus" = "xyes")