diff Makefile.am @ 24179:2f83c37c65e3

Move the NEWS check from automake's check-news to the version-check target. This causes it to abort 'make release' instead of 'make distcheck', like the other version checks.
author Ethan Blanton <elb@pidgin.im>
date Sat, 18 Oct 2008 18:14:32 +0000
parents 27556c2710e3
children b8fd4f37f9b2
line wrap: on
line diff
--- a/Makefile.am	Sat Oct 18 17:50:13 2008 +0000
+++ b/Makefile.am	Sat Oct 18 18:14:32 2008 +0000
@@ -34,6 +34,9 @@
 # We don't want to release development versions.
 	test x`echo $(PACKAGE_VERSION) | grep dev` = x
 
+# Make sure there is a NEWS entry for this version
+	head NEWS | grep "^$(PACKAGE_VERSION) (`date +%m/%d/%Y`):$$" > /dev/null
+
 # Ensure NEWS has no spaces at the start of a line.
 # Using spaces instead of tabs there is a common mistake.
 	test x`grep "^ " NEWS` = x