diff configure.ac @ 14696:34083fe39891

[gaim-migrate @ 17448] From Paul Betts, NetworkManager integration. This will smartly disconnect and reconnect accounts according to network availability. Probably needs some more tweaking. committer: Tailor Script <tailor@pidgin.im>
author Sean Egan <seanegan@gmail.com>
date Sun, 08 Oct 2006 08:40:09 +0000
parents d347b09626ee
children 1136736fdd2c
line wrap: on
line diff
--- a/configure.ac	Sun Oct 08 04:31:39 2006 +0000
+++ b/configure.ac	Sun Oct 08 08:40:09 2006 +0000
@@ -887,6 +887,14 @@
 		AC_MSG_RESULT(no)
 		enable_dbus=no
 	])
+
+dnl     Check for libnm_glib; if we don't have it, oh well
+	PKG_CHECK_MODULES(LIBNM, libnm_glib,
+	[
+    		AC_DEFINE(HAVE_LIBNM, 1, [Check to see if we have NetworkManager])
+	])
+	AC_SUBST(LIBNM_CFLAGS)
+	AC_SUBST(LIBNM_LIBS)
 fi
 
 dnl #######################################################################